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VoxcoTab - Overview 

VoxcoTab is a software application for creating statistical cross-tables. It operates on PCs running Windows (Millenium, 2000, XP) 

equipped with a version Microsoft .net 2.0. 

The source data to be processed can be in various formats: 

• ASCII files including multiple records. 

• Files produced by survey software: Conversoft, Quancept, Triple S, 

• Files produced by Cosi software. 

• Excel 

There is no limit on the volume of source data which can comprise one or several levels of cases (statistical units). 

VoxcoTab comprises 2 major process areas: 

• Creation of variables, and their configuration from the source data file, including all of the necessary recoding tools. This 
area involves the description of data which is useful at an individual case level. 

• Creation of tables, in which the preceding data is broken-out and cross-tabulated. Many tables can be produced at a time, 
configured with multiple options. 

Supporting modules are provided for: 

• Sample adjustment 

• Data export in various formats 

• Predictive model 

• Reports 

You can switch between modules instantly, enabling you to define variables, then define tables, execute them, take a look at the 

tables, go back and modify variables, return to the tables etc. 

Multiple file operation: All VoxcoTab operations (tables, exportation etc.) can operate with multiple files. For example, you can 

have a multiple wave study in which the files are processed sequentially as a single concatenated file. All you have to do is specify a 

list of these files in the file selection window. 

Ergonomics: If you are familiar with Windows, you will recognize your customary interface: menus, icons, mouse right-click, 

keyboard shortcuts etc. Use of a mouse is obligatory. 

VoxcoTab is designed to provide project managers with a reliable and powerful tool that is easy to use. Its recent design (2004) 

ensures that it is capable of adapting successfully to evolving trends in information technology (Windows, Internet.). 
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Studies 

Getting Started 

A study consists of a user-controlled process (involving variables, tables and tools) which is applied to a data file. 

When you launch VoxcoTab, the first menu asks you whether you wish to create, import, open or delete a study. 

 

When creating a study you must specify its path and title, together with a study number which VoxcoTab then incorporates into the 

names of all the study files. 

  

You must also indicate whether the study involves levels. 

If you know it already, you can specify the name of the source data file. If not, you can provide this at a later stage. 
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Opening an existing study: 

  

Importing a study : 

  

You can save the study that you are working on at any time, or save it under another study number. Furthermore, whenever you 

close a study, you will be prompted whether you wish to save your work. 

New Study 

Definitions 

You can configure a new study to have levels or not. A study with levels has several kinds of cases, while a study without levels has 

a single kind of case. 

Studies without levels. 

In a study without levels, the source data file to be processed may have zero, one, or several data record types . 

If there is no more than one data record type for each case, a case identifier is not needed (each data record represents a case). 

Nevertheless, even “single data record” cases can be assigned a type, thus permitting filtered selection of data records by their type, 

or different interpretation (reading) of the data record according to its type. However, when several types of data record can make 

up a single case (statistical unit) you are obliged to identify each one with its case identifier and record type. 

The case identifier is an alphanumeric field positioned anywhere in the record. Record types are determined by one or several rules 

specified in the Study Structure. 

Example: Case identifier in columns 1-5, and data record type in column 10 ( A, B, C or D). 

Important: The data file must be sorted in case identifier order, but the record type order is not important. 
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Data records which don’t belong to any declared type are ignored. Also, if more than one record bears the same case identifier and 

type, only the last one encountered in the file will be used. 

Comment : If several types of data record are declared, and no case identifier is declared, each data record will be considered to be 

a separate case, regardless of its type. 

Studies with levels 

There can be any number of levels, hierarchical or not, each applying to a specified set of variables for each case. 

Example: 

LEVEL VARIABLES 

1 Household Household size, region, equipment 

2 Personal Sex, age, profession 

3 Travel Mode of transport, origin, destination 

When using levels, you must specify their hierarchical relationship. The highest level is Level 1 ; each level (with the exception of 

Level 1) is dependent on a single higher level, called its Parent level. 

Note: Data files for studies with levels must be fixed position files i.e. field-delimited files are not recognized. 

In relation to the data file, each level corresponds to either: 

• One or several types of data records. Each record type is defined by one or several conditions applying to data in specified 
column positions in the data file. 

• Or, the level can be defined uniquely through its case identifier. Whenever this identifier changes, a new case is created at 
this level. 
 
This case identifier is required if there is more than one type of data record at this level, or if the level has Dependent 
levels. 

Only levels without Dependent levels may exist without a case identifier or type. In all situations, any declared data record, or all 

data records if no type has been declared at this level, will be considered as belonging to this level. 

At a given level, if no case identifier is specified, the end of data for this case/level is assumed when the defined data record types 

have been exhausted. On the other hand, if a level identifier is used, it must be used to identify all types of data records at this level, 

and for its dependents. 

The data file must be sorted on the identifier used for Level 1. However, all other data records in the same family (i.e. bearing the 

same identifier for Level 1) can be presented in any order. 

Declaring the structure of a new study 

There are two basic types of study: 

1. A study without levels, and with a single type of data record  (ASCII file with fixed column positions for the data, or a 
field-delimited CSV file). There is no structure to declare; you can create variables right away. 

2. A study using multiple data records, and/or multiple levels. For this type of study, you need to define the structure of 
the data file i.e the types of data record, and if applicable, levels and their structure. 

To access to the Study Structure window, click on the « define structure » button in the Toolbar: 

 

In the Study Structure window you can define the structure of the data file i.e. the types of data record and, if applicable, the level 

structure. 
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Defining data record types 

To create a new record type, right-click in the Record types field or press the Insert key; the Record type definition window appears: 

  

Each record type is defined through one or more Rules; each rule consists of a conditional test against a value taken from a specified 

character string in the data file. The From and To fields refer to the location of the character string.  The test uses the =, != ; >, <, 

<=, >= operators combined with a specified argument. 

To create or delete a condition, right-click in the Rules list area. 

You can also define sub-records, in which the record contains several cases whose variables are all offset by the same amount. In 

this situation you specify: 

• the step, assumed to be a constant, which separates two consecutive cases. 

• the number of sub-records i.e. the number of cases (statistical units) to create. 

Example: The record applies to a single person, the sub-records correspond to his/her n possible children described by the variables 

Sex, Age etc. 

Comments: 

• A record in the data file can belong to several types simultaneously though this not common. 

• If the study is declared without levels, and if you define sub-records, the only cases (statistical units) taken into account will 
be those corresponding to the sub-records. In the above example, only the children will be counted; not the individuals 
(parents). 

• When you use the sub-records option, if the variables do not have identical steps (column widths), for example a step of 1 
for Sex and a step of 2 for age, then you need to declare two types of record : one for sub-records with a step of 1, and 
another  for sub-record with a step of 2. The Sex and Age variables will be read from each of these sub-records 
respectively. 
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Defining levels 

To create a new level, right-click in the Levels structure pane. 

 

For each level you need to declare: 

• The name for the level 

• Its parent level (0 if it is already the highest level i.e. Level 1 

• The record type(s) applying to this level. For several record types, they can be listed separated by commas. 

• If applicable, the position of the case identifier for this level (From and To fields) 

• If applicable, the universe (sub-set) which conditionally selects for this level. 
 
In the Universe field you can put a logical variable allowing you to filter for (select) cases at this level meeting the 
conditions of this universe. Only those meeting the true condition will be considered. 
 
Cases filtered in this way will be the only ones taken into account during operations such as table computation, weighting, 
exporting etc. 

Comment: Even if a study does not have levels, you can use the first line to define a universe which filters for specific 
cases. 

Comments: 

• If a level references a record type containing sub-records, this level must be the lowest i.e. it must not have any 
dependents. 

• If a level references a record type containing sub-records, it may call other types of record which generate the same 
number of sub-records, but it may not call ‘normal’ records i.e. those which do not generate sub-records. 

• At the lowest level (one without a dependent), it is permissible not to have a case identifier provided that it calls record 
types with sub-records, or a single normal type record. 

• For any given level, if no record type is declared, then all of the records are assumed to belong to that level. 

• All of the above applies also to studies without levels, given that implicitly they consist of a single level (Level 1) without 
dependents. 
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Importing a study 

Overview - Importing a study 

Imported studies do not have levels. 

You can import from studies conforming to the data format of several software applications:: 

• Conversoft 

• Cosi 

• Quancept 

• SPSS 

• Triple S 

• Excel 

Importing from Conversoft 

You must have files created by Conversoft bearing the extensions sxd, sco et sci. 

1. In the File>Import menu, select Conversoft 

 

 

2. Indicate number of the study that you wish to create, together with its title and path. 

3. Specify the Convesort files bearing the extension sxd, sco et sci. 

4. When you click on OK, the study will be created. You can modify this study by adding variables, deleting source variables 
etc. 
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Importing from COSI 

You can import files created by Cosi’s Export command. The files bear the sct (script) and asc (data) extensions. 

1. In the File>Import menu, select COSI 
 

 

2. Indicate number of the study that you wish to create, together with its title and path. 

3. Specify the COSI files bearing the extension sct and asc extensions. 

4. When you click on OK, the study will be created. You can modify this study by adding variables, deleting source variables 
etc. 

Importing from Quancept 

The data file must be in ASCII mode (1 case=1 record), not in binary mode (1 case=n records). 

1. In the File>Import menu, select Quancept 
 

 

2. Indicate number of the study that you wish to create, together with its title and path. 

3. Specify the files which were created by Quancept. When Quancept creates the files it gives them the QDI and COL 
extensions but it does not matter if they have been renamed. 

4. When you click on OK, the study will be created. You can modify this study by adding variables, deleting source variables 
etc. 
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Processing specific to Quancept 

The instructions below assume that you are familiar with the format attributes of variables (described later in this user guide). 

Files produced by Quancept assign specific values for single or multiple variables: 

Value (string) Meaning 

1 0 Other values (OS) 

2 - No answer (NA) 

3 & Dont Know (DK) 

A value of 0 (zero) does not cause any problem, since it is accepted by VoxcoTab both for single and multiple response variables. 

However, the two other values are transformed as follows: 

• Multiple response variable: The special codes - and & are transformed, not only in the format assigned to the variable 
but also in the values read in the data file. They are converted to the new values -1 and -2 respectively. 

• Single response variable:In order to handle these 2 new codes (which are not numbers) VoxcoTab transforms the 
Quancept single response variable into a multiple response variable. The special codes - and & are transformed, both in the 
format assigned to the variable and also in the values read in the data file. They are converted to the new values -1 and -2 
respectively. However, given that this variable might be used in the calculation of means, the « value » column of the 
created format is initialized with the numerical values 1 to n. The special codes discussed above are not given values. 

 

Importing from SPSS 

You can import files bearing a SAV extension (produced by SPSS). 

1. In the File>Import menu, select SPSS 
 

 

2. Indicate number of the study that you wish to create, together with its title and path. 

3. Specify the SPSS files bearing the extension SAV. 

4. When you click on OK, the study will be created. You can modify this study by adding variables, deleting source variables 
etc. 
 
The corresponding data file will also be created under the name E_nnn.asc, where nnn is the study number you specified. 
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Importing from TripleS 

Note: TripleS files must have been created in XML format. TXT files are also admitted (since release 2.8) 

1. In the File>Import menu, select TripleS 

 

 

2. Indicate number of the study that you wish to create, together with its title and path. 

3. Specify the TripleS file. 

4. When you click on OK, the study will be created. You can modify this study by adding variables, deleting source variables 
etc. 

 

Importing Excel (xls or xlsx) 

You can import Excel files (xls or xlsx), from the File>Import menu. 

Variables are generated from the first line of the Excel file : 

The name of the variable is Vnn,where nn is the column numnber 

The type is ‘Text’ 

The title is taken from the column name 

The function is Input csv, with the correct column number 

a file Ennn_csv is provided as data file, the first line of the Excel file being deleted, and the character « ; » being used as delimiter. 

 Some advice to improve processing. 

The user is free to change the type of any variable, and can use the option « create format from data » to obtain the format for 
variables that will be used the tables. 
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Opening a study 

When you open a study (File>Open menu), the variables dictionary is displayed. 

You can: 

• Change the title of the study (Tools>Properties menu) 

• Modify the variables dictionary by adding, changing or deleting variables. 

Warning: If you delete variables used in different VoxcoTab modules (tables, export, weighting etc.x), the module in 
question might fail on execution. 

• Create tables (Tables tab). 

• Request file exportation (Utilities>Export  data menu) 

• Request weighting adjustment (Utilities>Weighting factor menu) 

File saving: All modifications made in the variables dictionary are saved when you select File>Save or File>Save As in the main 

menu. Hence, you can save the study in another directory and/or under another number. 

Quitting: If you quit VoxcoTab without using the File>Save or File>Save As commands, all changes will be lost. As a 

precautionary measure, you are always presented with a Save prompt when you quit, just in case you have forgotten to do so. 

Properties 

The Properties window is accessed from the Tools>Properties menu. 

It enables you to: 

• Create or modify the title of the study. 

• Specify the field delimiters and text qualifiers used in the CSV data files. 

• Specify the name of the data file to be processed. Several data files can be entered in this list, in which case their data will 
be concatenated virtually for processing as a single file. 

• Enable the 'Cache' option. See Cache File. 

• Specify the default font to be used when creating new labels in ‘Formats’. 
This choice is valid at the application level, not just at the study level. 

Deleting a Study 

The File>Delete menu allows you to choose a study and delete it. 

Note: You are prompted to confirm that you indeed wish to delete it 
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Variables 

Overview - Variables 

Variables contain source information for statistical tables. Each case in the source data file provides a value for each variable. 

Variables are created automatically when opening an existing study or importing one (they can, of course, be modified). When you 

create a new study, you must create its variables. 

The variables window is brought into view when you click on the Variables tab at the bottom-left of the screen: 

 

 

  

You can test for Errors in the variables list can be  clicking on the Check button in the toolbar: 

 

A Find/Replace tool, accessed through the  F3 key or Ctrl+F key combination, operates on any column in the list that you specify: 

 

Note: The tool also operates in the Formats and Functions columns. Note also that search strings are case-sensitive. 
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Variable Attributes 

Each variable is described through a set of attributes: 

Attribute Description 

Name Up to 16 alphanumeric characters, the _ (underbar) character is permitted. The name 

must start with a letter 

Level Applies only when the study was created and declared as a study with levels 

Dimension Applies when the variable comprises n occurrences i.e. when it represents a series of n 

questions which are identical apart from their titles. 

Type Type Description 

Single The value of the variable for a case is an integer (positive or negative), 

zero or the conventional default value Missing. 

Multiple A case can have several integer values simultaneously out of the set (-

2, -1, 0, 1, 2, 3, ...). By default, if none of these values is present, it 

has the conventional default value Missing. 

Quantity The value is a real number, or the conventional default value Missing 

Text The value is a string of n characters (n is defined in the variables 

Function field). The conventional default value (empty field) is Missing. 

Logical The value can be either TRUE or FALSE 

Note: A variable classified as Missing signifies that its data is missing or non-compliant. 

For example, alphabetic characters when a numerical value is expected. 

Format The assigned type: Single, Multiple or Text variables may have an assigned format 

comprising: 

• A list of codes (categories) to appear in tables whenever a frequency 
distribution is required. 

• Associated labels 

• Optionally, values (sometimes referred to as weights) to be used in place of 
numerical codes when calculating means. 

• Other formatting options. 

Title The title which is to appear in tables. 

Function The function used to assign a value to the variable (determining the source or content of 

the variable) 

Base A logical variable which operates as a case filter whenever the variable is used in a 

table. 
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Manipulating variables 

When you right-click on a variable's attribute, a context-sensitive menu is presented. If the complete line of a variable selected, all 

of the possible menu items appear: 

Note: Some of these commands are also a accessible from the Main menu. 

 

Function Main menu 

command 

Comments 

Copy Edit>copy Copies one or more variables from the same or another study. They are placed on the 

Clipboard. 

Paste Edit>Paste Pastes (from the Clipboard) variables copied from the same or another study. 

When pasting variables from another project, make sure that they do not bear the same names 

as your current project. If they do, the paste operation will be blocked. Besides, it is better to 

paste variables into a new line at the end of the variables dictionary to minimize the risk of 

pasting over existing variables. 

In any event, if a variable to be pasted has a format which already exists in the study, the 

existing format will be preserved. 

Insert Edit>Insert Inserts a new variable before the currently selected variable. 

Delete Edit>Delete Deletes the currently selected variable. 

Note: The whole line of the variable must be selected, by clicking in its (left-most) variable 

number column. 

Duplicate Edit>Duplicate Duplicates the currently selected variable. 

Reset   Clear 

Import Tools>Import Imports (one or more variables) 
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You are requested to specify the study, and to check the variables which you wish to import. 

When a variable to import bears the same name as an existing variable, you will be prompted 

choose whether to ignore the variable, rename it, or write over the existing variable. 

Imported variables come with all of their attributes included their formats. If the name of a 

variable's format already exists in the study, you will be prompted to choose whether to ignore 

the format, rename it, or write over the existing format. 

Link   This command is used for merging studies. See pour fusionner des études (voir § 3.9 

Frequency 

Table 

  Produces a pop-up frequency table of each of the variable's categories. See Frequency Tables 

Topic   Enables you to classify your variables into topics (which you define). These variables will 

thereafter be easy to identify in the variables list through the format and colour of the font 

which you have assigned to the topic. 

In the Topics window, a single-click enables you to Add/Remove a topic, and to give it your 

preferred font attributes. When you click on the Apply button, the currently chosen topic will be 

assigned to the variables currently selected in the variables list. 

 

References   Provides a list of all the variables used in defining the current variable. 

Referenced 

by 

  Provides a list of all the variables whose definitions use the current variable. 
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To reposition a variable in the variables list 

Select the variable and press the CTRL+Up/Down arrow on your keyboard. 

Note: This feature may sometimes be limited in order to maintain compatibility with the selected variable's functions and any 

variables which depend on it. 

To find or replace names, text strings 

The CRTL+F keys bring up the Find/Replace window where you can find variables by means of their name, title text string etc. 

Editing variable attributes 

The method for editing a variable's attribute depends on which kind of attribute is selected: 

Attribute Edit method(s) 

Name, Dimension Type directly in the field. The Name attribute may be left blank. 

Dimension: When you click on the + (plus sign) to the left of a dimension, the 

variable is expanded to show all of its occurrences. This enables you to assign a 

title to each occurrence, using copy/paste functions if you wish. 

Type Type the capital letter of the Type i.e. S,Q,M,T,L 

Click on Edit button to the right of the field. 

Notes: 

• You cannot modify the Type of a variable whose Type is currently Text 
together with a Format. 

• A variable which has a Format whose Type is currently Single can only be 
changed to Multiple, and vice versa. 

Format, Title, Function, Base Click on Edit button to the right of the field. 

A right-click in the field enables you to Copy, Paste-into and Reset (clear) the 

selected attributes of the currently selected variable(s). 

Level Type directly in the field. 

Note: The level you specify must comply with those defined in the Study 

Structure, or be 0 (zero). A variable set to level 0 includes (by convention) all 

cases, while any level greater than 0 includes only cases belonging to this level. 
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Formats 

Overview 

Formats apply to Single, Multiple or Text variables. They enable you to specify a variable's discrete categorization scheme whenever 

you need a variable's distribution (by single codes and/or subtotals). They also allow you to assign each code (category) with a 

numerical value which will be used in calculating means, in place of the numerical code itself. 

Formats are automatically generated when importing a study; bearing the name of the corresponding variable. 

Assigning a Format 

To assign a format to a variable, click on the button to the right of the Format field. You can: 

• Use an existing format which will then be also associated with the current variable. 

Note: A Text variable can only be assigned to a format that is associated with another Text variable. Similarly, a Single or 
Multiple variable can only be assigned to a format that is associated with another Single of Multiple variable. 

• Duplicate an existing format under another name. This option applies when you need to modify the format, but only for 
the currently selected variable. The format you select is presented in the Format definition window where you can modify 
it. 

• Import a format from another study (it must conform, of course, to the above restrictions). 

• Create a new format. When you have provided a name (1 to 8 characters), the Format definition window is presented. 

Creating a Format 

 

Each line (category) in the format will generate an item (row, column or page, according to the circumstances) in a table which uses 

the associated variable. The item corresponds to the variable's: 

• Code (an integer for Single or Multiple variables, a string for Text variables) 

• Range(s) of codes (in which case the item comprises the logical total of these codes) 

• No code, in which case the item will appear as a 'comment' line in the table. 

To each code or range of codes you assign a label (256 character max.) which will be displayed in place of the code in tables whose 

variables use this format. 

You must fill-out at least the Code and Label columns, thus providing a list of those variable's codes to be processed and included in 

tables requiring frequency distributions, and the labels to be displayed in place of the codes. 
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Specifying codes and labels 

You can do one of the following: 

• Insert. Delete or Duplicate a line, select and right-click on a line in the table. The pop-up window also allows you  Copy, 
Paste, and Reset. 

• Edit directly in the Code, Label and Value fields. You can use the arrow keys to navigate around the table. 

• Copy and paste directly in a field. For example, you can copy a list of codes or labels in an Excel spreadsheet, and 
paste them into the corresponding column. 

• Specify ranges and sets of codes for sums 

o The Sum function, available with a right-click of the mouse, will generate a new row in which the specified range of 
codes (sub-total) reflects the lines selected at the time. 

o To specify a sum consisting of a range or set of codes, you can also type them directly, using the range operators "-" 
and ";". Thus you can specify any valid codes, even if they don't already exist in the format. 
 

Example: 1-3; 5-22; 43-299 

o Another way to specify a sum consisting of a range or set of codes is to click on the button to the right of the Format 
field.  A code list is presented in which you select the codes you wish by means of the checkboxes provided. 

Formatting labels 

You can specify the Font, style, or size of one or more labels at a time. Select the line(s) and right-click the mouse for access to 

the Font Configuration window. 

Indentation of the selected label(s) to the right or left is also accessed by a right-click of the mouse. 

Blank code. If you specify a label, and the accompanying code is blank, this enables an empty row or column to appear in a table 

using the variable. 

Line exclusions 

The No Sort checkbox will exclude its line when a table using the variable is sorted. 

The NE checkbox will exclude the line in a table. 

Note: To choose the options "No sort" and “Hide”, you can select several boxes and use the Check All option available with a right-

click of the mouse 

Values 

The Value field allows you to assign values (with decimals) to the corresponding codes. When using this feature, means or sums in a 

table using the variable will based on these values. Certain conditions apply: 

• When assigning values to codes, any codes (categories) for which no value has been specified will be excluded from means 
or sums. In the event that no code has been assigned a value, means and sums will be computed on the value-equivalent 
of the codes. 

• Values assigned to codes (categories) based on a range of other codes (i.e. more than one code) are excluded from means 
and sums. 

• For a multiple variable, its value will be the sum of the values of the selected codes. If any of the selected codes does not 
have an associated value, the value of the variable will be classified as Missing. 

Formatting tables 

You can reposition a selected line (code) in the list by means of the CTRL+Arrow Up or Arrow Down keys. This positioning will be 

reflected in all tables using this format. 

The use of formats enable you to configure the presentation of a variable in tables in categories which can include ranges of codes 

without the need to create new variables. 

The number of lines (categories) thus described in the format is shown in the main Variables screen (in parentheses), following the 

format name. 

If a format is assigned to several variables, it can be modified from any one of these variables. 
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Automatic format generation 

This option, accessible through the Tools>Create Formats from data... menu, automatically creates formats for all Single, Multiple 

or Text variables which do not already have a format. It reads the source data file, generates a line for each unique value for the 

variable, and copies each value into both the Code and Label field.  You can then modify these labels, and create code groupings 

using the Sum function etc. 

You can use this option to obtain a value distribution for all variables whose categorization is unknown. 

You can also apply the option to a single variable. To do so, position the cursor on the variable's line; a right mouse-click allows you 

to select the option "Automatic formation generation for this variable". Note: The option will be ignored if the variable already 

possesses a format. 

Examples of Formats 

1. Creation of value ranges (only). 
 

 
 
Only the value ranges are included. The variable is not recoded, thus preserving the true values for calculating means. 

2. Editing of codes, sub-totals, and means calculated on new values. 
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Functions and Operations 

Overview - Functions 

The role of functions is to provide variables with values whether by reading the source data file, reading an external table, or through 

any operation which re-codes other already defined variables. The last function listed in this section (CPL function) enables you to 

write a procedure in the CPL language through which you can assign values to the current variable, or any variable which precedes 

it. The CPL language is described in the section on Procedures. 

When you call a function, by clicking on the button to the right of the Function field, the list presented includes only those functions 

appropriate for the variable's attributes i.e. type, dimension, level, and whether a format has been specified. 

  

For any given variable, a function can only reference in its argument variables which precede it in the Variables List. 

Conversions. Several functions required the conversion of values before they can be executed. For example, an arithmetic 

operation resulting in a Single type variable (hence an integer), and in which an operand is a Quantity variable (real number), 

requires that the Quantity variable be truncated to an integer before the function is executed. 
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Input function (ASCII) 

A variable assigned with the Input function takes on its value while reading a record in a text input file. Usually each case 

corresponds to a single data record, and you only have to specify its position in the data record. In other, less usual, circumstances, 

you must specify both the record type in which data is located. and its position in this record. 

If no type is specified, the data will be read from all types of data record. 

  

The input field is specified through its starting and ending position (From, To). Note: The first position in a record is called 1, not 0 

(zero). 

For a Multiple variable, you specify the starting and ending position of its first value. The Values step, i.e. the number of positions 

between each value, and the Number of values are optional attributes for this function. 

For a Dimensioned variable, you specify the starting and ending position of the first occurrence. The Occurrences step indicates 

the number of positions between one occurrence and another. 

The values expected in the data records field depend on the variable type: 

Variable type Type of value 

Single Integer. It may carry a sign, and have leading or trailing blanks. Hence [bb][S]nnn[bbb] results in the value 

nnn (possibly with a sign. Anything else in the input field results in a missing value. 

Quantity A number with a decimal point. It may carry a sign, and have leading or trailing blanks. Hence, 

[bb][S]nnn.nn[bbb] result in the value nnn.nn (possibly with a sign). An integer without a decimal point is 

accepted as well, but anything else results in a missing value. 

Exception for Single and Quantity variables. If the Spaces to zero option is checked, then an empty field results in a value of 0 

(zero). 

Multiple  There two input modes: 

Mode Description 

By Value A value is taken from each field (the number of fields being the specified Number of 

values ). Each field must contain: 

• An unsigned integer, with leading or trailing blanks permitted. Hence, [b]nn[b] 
results in the value nn. 
  

• The characters "-" or "&" which are converted, as they are read, into the values -
1 and -2 respectively. See Importing from Quancept files. 

Non-compliant values are simply  ignored. 

Example: When reading the 4 values of  6, 35, XY and blank, the result is 2 values i.e. 6 , 

35. 
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Note: The variable is only classified as missing when none of the values comply. 

By Rank In this mode, the n positions in the data field correspond to the values 1 to n respectively 

for the variable. Hence, the variable will take on the value j, if, and only if, there is a non-

blank and non-zero character in the jth position in the data field. 

  

Text All text is accepted without any conversion, however leading and trailing blanks are removed. The width of 

the data entry field will be assigned to the variable as if this were its specified character width. 

Logical A positive integer, optionally with a sign, and permitting leading or trailing blanks. Hence, 

[bb][S]nnn[bbb]  results in a value TRUE. Anything results in the value FALSE. 
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Input CSV function 

This function allows you obtain a variable's data from a CSV file, provided the study does not have levels, and has a single data 

record type. 

The CSV field separator (space, tab, comma (,) or semi-colon (;) is set in the File>Properties menu: 

 

To read the correct data into the variable, you simply specify its Field Number in the file: 

  

In all other respects, the options and behaviour are the same as for the Input Function (ASCII) i.e. for Multiple and Dimensioned 

variables, and the treatment of non-compliant data values. 
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Import function 

A variable using the Import function obtains its value, not from the principal data file, but from an external table. See External 

Tables. 

 

The Import Function window is similar to the Input Function window, except that the Record Type field is replaced by a Link in 

Import File field in which you choose a link from a list of one or more links already defined in the External Tables module. 

Once the appropriate record in the external table has been found i.e. whose index key(s) match those for the case, the data is read 

in exactly the same way as the Input function. 

Comment: Loading of data from the external table is performed dynamically whenever VoxcoTab needs to compute a variable using 

the import function, hence up-to-date index key variables are always used. 

Warning: If you change the value of these index keys, (using procedures, for example) you might be reading data from two 
different records in the External table. 

Dimensioned variables - special circumstance 

For a dimensioned variable, if the index keys in the external table are not dimensioned, the data from the selected record in the 

table is still read into the dimensioned variable, and the Step is used to calculate the position of each occurrence (as in the Input 

function). 

If at least one of the index keys in the external table is dimensioned, the data is read differently. Each occurrence will be read from a 

different record (defined by the Occurrence for the key). Hence, only the Starting position is significant, and any Step that might be 

specified is ignored. 
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Import CSV function 

This function enables you to obtain variable data from an external table in CSV format. The field separator character can be a space 

character, tab character, comma (,) or semi-colon (;). You determine the field separator in the File>Properties menu. 

The Import CSV definition window is identical to the Import definition window, with the exception that you specify a Field number 

(rather than the position of the data) in the external lfile. 

In all other respects, the function is identical to the Import Function. 
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Arithmetical Operations 

Operands can be: 

• Non-dimensioned variables, or occurrences of dimensioned variables 

• Dimensioned variables 

• Constants 

 

You may use up to 20 operands. 

Both the resulting variable and variables used as operands must be numeric i.e. Single or Quantity type. 

If the resulting variable is of Single type (S), then the operand values are truncated to integers before calculation. Hence, the 

calculation is performed in integers, and the result will be an integer.   

If the resulting variable is of Quantity type (Q), calculation is floating point. If the resulting variable is dimensioned, then all of the 

operand variables must be similarly dimensioned or be undimensioned. Calculation is performed for each occurrence. 

Operators comprise: * (multiplication), / (division), + (addition), - (subtraction) and ^ (exponentiation). 

Priority of execution is ^, followed by * and /, finishing with + and -. 

When operators have the same priority, the order of execution is from left to right. 

A MISSING result will occur in three situations: 

• Division by zero 

• Whenever any of the operands has a MISSING value 

• The conditional Universe applying to the function has not been verified. 

Conditions 

    Resulting 

Variable 

Argument 

Variable 

Base 

Variable 

Attribute 

Type S or Q S or Q L 

Level i i or <i i or <i 

Dimension undimensioned undimensioned undimensioned 

n undimensioned or 

dimension n 

undimensioned or 

dimension n 

If the base is dimensioned, the only occurrences of the resulting variable that will be considered are those whose corresponding 

occurrence in the base is TRUE. The other occurrences will be classified as MISSING. 
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Logical Operations 

A Multiple variable can be built from other variables (Multiple or Single type variables) using a logical AND, OR , XOR (Exclusive) or 

EXCEPT operation.  Integer constants may be used. 

Tne number of operands may not exceed 20. 

Example: 

Variable B1 has values 1,2,3,4 

Variable B2 has values 3,4,5,6 

Operation Result 

B1 OR B2 1,2,3,4,5,6 

B1 XOR B2 1,2,5,6 

B1 AND B2 3,4 

B1 EXCEPT B2 1,2 

Rules and behaviour: 

• Missing Values 

Situation Result 

X AND MISSING MISSING 

X OR MISSING X 

X XOR MISSING X 

X EXCEPT MISSING X 

• There is no priority between operators: operations are performed from left to right: 
Example: B1 OR B2 AND B3 is interpreted as (B1 OR B2) AND B3 

• The constant MISSING is represented by @NA 

• Operand variables must have the same dimension as the result variable, or be non-dimensioned variables, or refer to a 
specific occurrence. 

• The values of Single type variables are converted to multiple type before the operation is executed (0 to n produces 0 to n, 
other values produce Missing). 

Conditions 

    Resulting 

Variable 

Argument 

Variable 

Base 

Variable 

Attribute 

Type M M or S L 

Level i i or <i i or <i 

Dimension undimensioned undimensioned undimensioned 

n undimensioned or 

dimension n 

undimensioned or 

dimension n 

  

• If the base is dimensioned, the only occurrences considered in the resulting variable are those whose corresponding 
occurrence in the base is TRUE. Conversely, the occurrence becomes MISSING. 
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Recoding function 

This function enables you to define a category of a formatted variable in terms of one or more categories or value ranges of another 

(source) variable - this is sometimes known as recoding. 

The type of variable to which the function is applied i.e. the resulting variable, can be Single, Multiple or Logical; and it must have 

been formatted to have at least one category. 

Note: The conditions concerning Logical variables are somewhat special, so a special paragraph is devoted to them below. 

The Recode function definition screen provides a button for selecting the source variable (applying to the category currently selected 

in the list ), and, if applicable, a checkbox for constraining the function to only one (single) source variable applying to all categories. 

Note: Even if the resulting variable's format contains multiple codes (such as sub-totals),  they are not presented for recoding.   

  

Specifying source variables 

To specify a single source variable for all categories of the resulting variable 

1. Make sure that the Single Source option is checked 

2. In the first category in the list, select the Variable field. 

3. Click on the Select button. 

4. In the Variable list that pops up, select the source variable. 
This variable will become the source variable for all the categories in the list. 

To specify a different source variable for each category of the resulting variable 

1. Uncheck the Single Source option. 

2. Select the Variable field for one or more categories in the list 

3. Click on the Select button. 

4. In the Variable list that pops up, select the source variable. 

5. Repeat from step 2 for one or more categories until all of them have source variables defined. 

Assigning groups of categories or value ranges 

The Grouping column is where you set groups of categories or value ranges for each category of the resulting variable. You can type 

in your specification directly, using the syntax described below: 

Source Variable 

type 

Argument Syntax (examples) 

Quantity Real number • 0-44 signifies 0 to 44, 

• 18-24 ; 35-44 signifies from 18 to 24 
or from 35 to 44, Single or Multiple Positive integer or zero 
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Text Character string • 1-3 ; @NA signifies 1 to 3 or 
MISSING, 

• 45- signifies 45 or more 

• -44 signifies 44 or less 

• A-D signifies from the uppercase 
ASCII character A to D , in ASCII 
code order. 

Logical Permitted values are 1 or 0 

(representing TRUE or FALSE) 

All @NA (missing) or 

-  Indefinite (or less or more) 

  

Using the By Values (F5) and By List buttons (F6) 

Instead of typing your grouping or value range specification for a category, you can make use of the By Values and By List wizards 

to help you generate it. 

To use the By Values wizard 

1. Select a category in the Grouping column. 

2. Click on the F5 button or press the F5 key. The Value Ranges  screen will appear: 

 

3. Fill out the From and To values of the range(s) that are to apply. If you need to specify "or less' or "or more" in the From or 
To column respectively, you can use the F7 key or click on the F7=Indefinite button. The F7=Indefinite button. 
 
To specify "Missing", use the F8=@NA button or press the F8 key. 

4. Repeat from Step 1 for each category for which you need to provide ranges of values. 

To use the By List wizard 

You can use this wizard on categories whose specified source variable has itself been formatted to have categories. 

1. Select a category in the Grouping column. 
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2. Click on the F6=by list button or press the F6 key. The source variable's Recode List screen will appear: 

 

Note: This list only displays the source variable's single code categories for selection. Category code groupings (for nets or 
subtotals) are excluded. 

1. Select the codes that you wish to be grouped into the resulting variable's category. 

2. Repeat from Step 1 for each category for which you need to provide code groupings. 

Note: You can use mouse right-click for copy and paste functions 

Variable types 

Variable Type Description 

Text 

Source variable 

When specifying code strings, quotes should not be used; the quotes visible on 

subsequent display are automatically inserted by VoxcoTab to highlight the fact 

that a text variable is involved. 

Character order conforms to ASCII: 0 to 9, followed by A to Z, followed by a to z. 

Logical 

Source variable 

Permitted values are 1 and 2 (TRUE and FALSE) 

Dimensioned 

Resulting 

variable 

If the source variable is also dimensioned (same dimension), recoding is 

performed occurrence by occurrence. 

If the source variable is not dimensioned, or if a specified occurrence is 

concerned, recoding is performed according the values of the non-dimensioned 

variable for each occurrence of the resulting variable. This rule applies to each 

category of the resulting variable. 

Conditions 

    Resulting 

Variable 

Argument 

Variable 

Base 

Variable 
Attribute 

Type M, S or L M,S,Q,T or L L 

Level i i or <i i or <i 

Dimension undimensioned undimensioned undimensioned 

n undimensioned or 

dimension n 

undimensioned or 

dimension n 
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Execution 

For a Single type resulting variable, the first category encountered that meets its grouping specification will be the one selected. 

For a Multiple type resulting variable, all categories meeting their grouping specification will be considered. 

Warning: When a grouping specification applies to a Text type variable, string matching is limited to the number of characters of 
the shortest string. 

Logical resulting variables 

A logical variable cannot have a format i.e. categories; its state can be either TRUE or FALSE. Nevertheless, you can have several 

grouping specifications, each one resulting in TRUE. 

When you launch the Recode function, a single line is presented bearing the label TRUE. The resulting variable will be TRUE if your 

source variable matches your grouping specification. You can add more lines, each with its own grouping specification. During 

execution, your resulting variable will be TRUE only if each and every grouping specification is satisfied. 

Example: 

 

The result will be TRUE for women aged 18-25. 
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NBRESP (no. of responses) function 

Counts the number of codes selected in a multiple variable, regardless of its number of formatted categories. 

The resulting variable must be Single type, and the argument variable Multiple type. 

 

If the base is dimensioned, only those occurrences in the argument variable whose corresponding occurrences in the base are TRUE 

will be counted. 

The result is a number from 0 to x if the base is true, and Missing if the base is false. 

Conditions 

    Resulting 

Variable 

Argument 

Variable 

Base 

Variable 

Attribute 

Type S M L 

Level i i i or <i 

Dimension undimensioned undimensioned undimensioned 

n undimensioned or 

dimension n 

undimensioned or 

dimension n 
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NBVAL function - Number of non-missing values for a dimensioned 

variable 

Returns the number of occurrences of a dimensioned variable which are not MISSING. 

Conditions 

    Resulting 

Variable 

Argument 

Variable 

Base 

Variable 

Attribute 

Type S M, S, Q, T, L L 

Level i i i or <i 

Dimension undimensioned Dimension=n undimensioned or 

dimension=n 

Execution 

The result is the a number from 0 to x if the base is TRUE, and MISSING if the base is FALSE. 

If the base is dimensioned, only those occurrences in the argument variable whose corresponding occurrences in the base are TRUE 

will be counted. The result is MISSING if all of the occurrences in the base are FALSE. 

 

SUMVAL (sum of values) function for a dimensioned variable 

This function behaves differently depending on whether the type of the resulting variable is Single (or Quantity) or Multiple. 

• For a Single or Quantity resulting variable, the sum of the various occurrences of the source variable is computed. 

• For a  Multiple resulting variable, the union of the various occurrences of the source variable is taken. 

Conditions 

    Resulting 

Variable 

Argument 

Variable 

Base 

Variable 

Attribute 

Type M M or S L 

Type S or Q S or Q L 

Level i i i or <i 

Dimension undimensioned Dimension=n undimensioned or 

dimension=n 

Execution : 

• As imposed by the type of resulting variable, the necessary conversions are made before performing the sum (Single to 
Multiple, Quantity to Single etc.) 

• If the resulting variable type is Single or Quantity, and if one of the occurrences of the argument variable is MISSING, the 
resulting variable will also be MISSING. 

• The result will be a number between 0 and x if the base is TRUE, and MISSING if the base is FALSE. 

• If the base is dimensioned, only those occurrences in the argument variable whose corresponding occurrences in the base 
are TRUE will be counted. The result will be MISSING if all of the occurrences in the base are FALSE. 
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Dicho1 function - Distribute a Multiple variable to a dimensioned 

Single variable 

This function will also accept a Single type variable as an argument. 

Conditions 

    Resulting 

Variable 

Argument 

Variable 

Base 

Variable 

Attribute 

Type S M,S L 

Level i i i or <i 

Dimension dimension n undimensioned undimensioned or 

dimension n 

  

Execution 

• The recognized codes of the argument variable are 1 thru n, where n is the dimension of the resulting variable (codes 0,-1 
and -2 are ignored).   

• When the argument variable contains the code j, the jth occurrence of the resulting variable is set to 1 (if not, the jth 
occurrence will be set to MISSING. 

• If the base is dimensioned, only those occurrences in the resulting variable whose corresponding occurrences in the base 
are TRUE will be fillled. 

 

DICHO2 function - distribute a dimensioned variable to a Multiple 

variable 

Values of occurrences (lying within a specified range) generate corresponding codes of the Multiple variable. 

Conditions 

    Resulting 

Variable 

Argument 

Variable 

Base 

Variable 

Attribute 

Type M S,M L 

Level i i i or <i 

Dimension undimensioned dimension n undimensioned or 

dimension n 

Execution 

• When the value of occurrence j of the argument variable is within the specified range, the resulting variable is assigned 
code j. 

• If the base is dimensioned, only those occurrences in the argument variable whose corresponding occurrences in the base 
are TRUE will be taken into consideration. 



 

46 

 

NBLEV function 

Note: This function only applies to studies with Levels. 

The function returns the number of dependents in the case being processed, whose argument variable is not MISSING. 

Conditions 

    Resulting 

Variable 

Argument 

Variable 

Base 

Variable 

Attribute 

Type S M, S, Q, T, L L 

Level i j > i and j 

depending on its 

parent level i 

j or <j 

Dimension undimensioned undimensioned undimensioned 

dimension n dimension n undimensioned or 

dimension n 

Execution 

• The notion of dependent derives from the study structure (Level Definition screen) 

• The result is a number between 0 and x if the base is TRUE, and MISSING if the base is FALSE. 

• If the base is dimensioned, only those occurrences in the argument variable whose corresponding occurrences in the base 
are TRUE will be taken into consideration. 
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SUMLEV function 

This "Lower Level" sum function applies only to studies with Levels. 

For the argument variable, returns the sum of the values of all dependents for the case being processed. 

For the result variable, the behaviour depends on whether it is a Single (or Quantity) or Multiple type variable: 

• Single (Quantity) type variable: Arithmetical sum 

• Multiple type variable: The Logical sum (union) of the argument variable (which is the dependent level) is written to the 
resulting variable (its parent). 

 Conditions 

    Resulting 

Variable 

Argument 

Variable 

Base 

Variable 

Attribute 

Type M M,S L 

S S,Q L 

Q S,Q L 

Level i j > i and j 

dependent  i 

j or <j 

Dimension undimensioned undimensioned undimensioned 

dimension n dimension n undimensioned or 

dimension n 

  

Execution 

• If the resulting variable is arithmetic (Type S or Q), and if the argument variable has any MISSING value, the result will be 
MISSING. 

• The result is a number between 0 and x if the base is TRUE, and MISSING if the base is FALSE. 

• If the base is dimensioned, only those occurrences in the argument variable whose corresponding occurrences in the base 
are TRUE will be taken into consideration. 
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CONST function 

This function enables you to create a table of constants within a variable (either dimensioned or undimensioned). The variable should 

not have a Base (even if it does, it will be ignored). 

The type of the resulting variable can be Multiple, Single, Quantity or Text. 

For a Multiple variable, the different values must be separated by commas: 

 

For a Dimensioned variable, the different values are entered on each row: 
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TABLE function 

This function enables you to pick a value from a table by means of an index variable. 

The resulting variable takes its value from a dimensioned variable (first argument) selected by an index variable (second argument). 

RESULT= TABLE [Index] 

Conditions 

    Resulting 

Variable 

Argument 

Variable 

Index Variable Base 

Variable 

Attribute 

Type M M,S S L 

S S,Q S L 

Q S,Q S L 

T T S L 

Level i i or <i i or <i i or <i 

Dimension undimensioned dimensioned undimensioned undimensioned 

dimension n dimensioned dimension n undimensioned 

or dimension n 

Execution 

• Any necessary conversions are made automatically. 

• If the resulting variable is dimensioned, it need not have the same dimensions as the table variable: RES [ j] = TABLE [ 
INDICE (j) ] 

• If the base is dimensioned, only those occurrences in the resulting variable whose corresponding occurrences in the base 
are TRUE will be taken into consideration. 

• The final result is MISSING if the base is FALSE. 
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CONCAT function 

This function can assemble a dimensioned variable by grouping together several other variables (dimensioned or not). Several types 

of source and resulting variable are supported. 

The resulting variable can be assembled from several dimensioned variables. In all cases, it must be dimensioned to equal the sum 

of the dimensions of the source variables; an undimensioned variable having a dimension of 1. 

With regard to variable types: 

• A Multiple type variable can be assembled from both Multiple and Single variables. 

• A Single (or Quantity) type variable can be assembled from Single or Quantity variables. 

• A Text variable can be assembled from Text variables. 

Note: To select occurrences of a dimensioned variable, select the variable and press SPACEBAR. This will expand the variable to 

display all of its occurrences for selection. 

Conditions 

    Resulting 

Variable 

Argument Variable Base 

Variable 

Attribute 

Type M M,S L 

S S,Q L 

Q S,Q L 

T T L 

Level i i or <i i or <i 

  

dimension n undimensioned or 

dimensioned (sum of 

dimensions=n) 

undimensioned or 

dimension n 

  

If you wish, you can title the occurrences in the resulting variable using the corresponding titles of the source variables. To do this, 

use the Update occurrence titles checkbox. 

Execution 

• Type conversions are made as required. 

• If the base is dimensioned, only those occurrences in the resulting variable whose corresponding occurrences in the base 
are TRUE will be counted (all others will MISSING). 

• The final result is missing if the base is FALSE. 
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MIN and MAX functions 

Minimum and Maximum in a set of variables 

These functions apply to either: 

• A dimensioned variable. To return the Minimum or Maximum value among its occurrences, or 
  

• Levels. To return a variable's Minimum or Maximum within a dependent level. 

 

When you click on the Variable button, the displayed list of variable offers for selection only those which comply with the Conditions 

table(s) below. 

Conditions 

1. Maximum or minimum within occurrences of a dimensioned variable. Applies if the level of the resulting variable is the same 
as the argument level, or if the study does not have levels. 
  

    Resulting 

Variable 

Argument 

Variable 

Base 

Variable 

Attribute 

Type S S, Q L 

Level i i i or <i 

Dimension undimensioned Dimension=n undimensioned or 

dimension=n 

2. Maximum or minimum between levels. Applies if the study has levels, and if level j of the argument variable is greater that 
the level of the resulting variable. 
  

    Resulting 

Variable 

Argument 

Variable 

Base 

Variable 

Attribute 

Type S S, Q L 

Level i j > i and j is a 

dependent of i 

i or <i 

Dimension undimensioned undimensioned undimensioned 

Dimension=n Dimension=n undimensioned or 

dimension=n 

  

Execution (all conditions) 

• Type conversions are made as required. 

• By convention, a MISSING value is considered to be the smallest value. 

• If the base is dimensioned, only those occurrences in the argument variable whose corresponding occurrences in the base 
are TRUE will be considered. 

• The final result is MISSING if the base is FALSE. 
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RANK and RANKNF functions - Case ranking 

Rank refers to the sequence number of a case being processed. The Rank function increments the case sequence number only for 

cases belonging to a specified universe i.e. those that are TRUE when associated with a logical variable in the universe of the study 

structure. The RANKNF function, on the other hand, increments the case sequence number for all cases whether or not they belong 

to the specified universe. 

For a study with Levels, the rank of a case belonging to Level j>1  is its rank within its peers. 

There is no argument, or supplementary input screen, with this function. 

Conditions 

    Resulting 

Variable 

Base 

Variable 

Attribute 

Type S L 

Level i i or <i 

Dimension undimensioned undimensioned 

Execution 

With Levels: 

The variable using this function will have a value corresponding to the rank position of the case within the group of cases being 

processed (sequence number possibly limited to the filtered cases) 

Without Levels: 

If the resulting variable is Level 1, its value will be rank of the case at level 1 with respect to the whole data file. 

If the resulting variable is in a dependent level, cases with the same parent will be ranked starting from 1. 

Warning: A variable defined using the Rank function must not be used as an argument in another variable's function. 

 

GETLEV function - Get Level 

This function returns a value equivalent to the level being processed. Usually, it is used with a variable whose level is 0. 

There is no argument, or supplementary input screen, with this function. 

Conditions 

    Resulting 

Variable 

Base 

Variable 

Attribute 

Type S L 

Level i i or <i 

Dimension undimensioned undimensioned 
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CONV functions 

These functions allow you to convert between various value types. 

Conditions 

    Resulting 

Variable 

Argument 

Variable 

Base 

Variable 

Attribute 

Type S. T. L M,S, Q, T L 

Level i i i or <i 

Dimension undimensioned undimensioned undimensioned 

dimension n undimensioned 

or dimension n 

undimensioned or 

dimension n 

Text-type resulting variable 

As a general rule, an argument variable which is MISSING produces MISSING in the resulting variable. 

Single to Text 

Values can be right-justified packed with either leading blanks or zeros. They can also be left justified. 

Warning: If the field width is insufficient to represent a value, the result will be MISSING. 

  

Quantity to Text 

 As, in Single type to Text type, values can be right-justified packed with either leading blanks or zeros. They can also be left 

justified. However, the number of decimals must also be specified. 
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Multiple to Text 

  

 

Two format options are available: 

• By values (fixed format):  You specify the string length to be used for each value. 
  

• By rank (Each category of the source variable is coded 0 or 1): You specify the total length of the resulting variable i.e. 
the number categories to be taken. 

Note: The 1st position in the output string corresponds to the value of 0 of the argument variable. The 2nd position codes 
the 1st category of argument variable etc. In other words, the character 1 in position j signifies that category j-1 in the 
argument variable is present. 

Example: Take a source variable (Multiple) with codes 2, 4 and 8 selected 

The resulting strings would be: 

• By values (with string length of 2 for each value specified): " 2 4 8" 

• By rank (with total string length of 9 specified):  "001010001" 

Note: If the string length were 7, then the last "01" representing the codes 7 and 8 would be truncated. 

Logical-type resulting variable 

There are no options. Whatever be the type of argument variable, the result is FALSE if the argument variable is MISSING, and TRUE 

otherwise. 

Single-type resulting variable 

As a general rule, if the argument variable is MISSING then the resulting variable will be MISSING. 

Multiple to Single 

There are no options. The result is a number obtained by taking the sum of all the values 2**j, j being one of the argument 

variable's values, that is to say: 

j 2**j 
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0 1 

1 2 

2 4 

3 8 

4 16 

5 32 

etc. 

  

 

If the argument variable has values (1,2,5), the result will be 2 + 4 +32=38. 

The aim of this conversion formula is to uniquely represent all possible combinations of the argument variable's values. 

Quantity to Single 

 You are offered the choice of rounding or truncating the argument variable's value. 

 

Text to Single 

There are no options. The argument variable must represent an integer; it  may be signed and have leading or trailing blanks. 

[bb][S]nnn[bbb] results in the value nnn together with its sign, otherwise the result is MISSING. 
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TIME and DATE functions 

In all of these functions, date and time is expressed in a Text type variable whose form is: 

• YYYYMMDD : Year, Month, Day (8 characters), or 

• YYYYMMDDHHMMSS : Year, Month, Day, Hours, Minutes, Seconds (14 characters) 

(Depending on the function, this Text type variable is involved either as an argument or result). 

CurDate and CurTime functions 

For these functions there is no input screen i.e. there is no argument to supply. 

The resulting variable must be an undimensioned Text type variable. 

The result is: 

• Current Date: A string of 8 characters in the form YYYYMMDD. 

• Current Time: A string of 6 characters in the form HHMMSS. 

Year, Month, Quarter, DayWeek, DayYear and Week functions 

The resulting variable must be an undimensioned Single type variable. The argument variable must be an undimensioned Text type 

variable in the form YYYYMMDD. 

As their title suggests, these functions return respectively (from the argument variable): Year, Month, Quarter, Day of the Week, 

Day of the Year, and Week of the Year. 

For the Month and DayWeek functions, a format is automatically created for the resulting variable comprising the labels January thru 

December, and the labels Monday thru Sunday. 

Note: The Week function returns a number comprising the Year and the Week number in the format YYYYWW. 

The calculation is Year*100+Week No. 

Conditions 

    Resulting 

Variable 

Argument 

Variable 

Base 

Variable 

Attribute 

Type S T L 

Level i i or <i i or <i 

Dimension undimensioned undimensioned undimensioned 
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Difference between dates 

Two date/times in the form of undimensioned text variables or constants are compared. You can choose the units in which the 

difference is computed. 

  

Conditions 

The resulting variable must be Single type and undimensioned 

    Resulting 

Variable 

Argument 

Variable 

Base 

Variable 

Attribute 

Type S T L 

Level i i or <i i or <i 

Dimension undimensioned undimensioned undimensioned 

 

  



 

58 

 

AddTime function : Add time duration to a date 

The function takes a start date and time (constant or undimensioned variable), a time duration to be added (constant or Single type 

variable, negative or positive), and the unit in which the time duration is expressed. 

  

The result is a date (Text variable, width 8 or 14 depending on the start date). 

Conditions 

    Resulting 

Variable 

Argument 

Variable 

Base 

Variable 

Attribute 

Type T T, S L 

Level i i or <i i or <i 

Dimension undimensioned undimensioned undimensioned 
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CHAIN function 

This function will concatenate (join together) several character strings. 

Conditions 

    Resulting 

Variable 

Argument 

Variable 

Base 

Variable 

Attribute 

Type T T L 

Level i i or <i i or <i 

Dimension undimensioned undimensioned undimensioned 

undimensioned undimensioned or 

dimension n 

undimensioned 

Execution 

• The length of the resulting variable is the sum of the lengths of the source (argument) strings. 

• Any occurrences of the source variable(s) will be concatenated sequentially. 

• If the base is FALSE, the final result will be MISSING. 
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SUBSTR function 

Extracts a sub-string from a Text type variable. 

The arguments are the length and starting position of the sub-string in the source variable. They can be specified either as variables 

(Single type) or constants. 

Conditions 

    Resulting 

Variable 

Source 

Variable 

Variable indicating 

position and length 

Base 

Variable 

Attribute 

Type T T S L 

Level i i or <i i or <i i or <i 

Dimension undimensioned undimensioned undimensioned undimensioned 

dimension n dimension n undimensioned undimensioned or 

dimension n 

Execution 

• The indicated number of characters starting at the specified position in the source variable are copied into the resulting 
variable. 

• The length of the sub-string to be extracted is limited to the length of the source string. 

 

POSTR function 

Returns the position of a specified sub-string first encountered within a character string. 

Both the string and sub-string can be specified either as variables or constants. 

Conditions 

    Resulting 

Variable 

Argument 

Variable 1 

Argument 

Variable 2 

Base 

Variable 

Attribute 

Type S T T L 

Level i i or <i i or <i i or <i 

Dimension undimensioned undimensioned undimensioned undimensioned 

dimension n dimension n undimensioned undimensioned 

or dimension n 
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TmutS function 
With function TmutS, a variable of type Single obtains its value from a variable of type Text : resulting values 1 to n corresponding 
to the n lines of the format of the variable text:  
 

 

 
Conditions 

    Resulting 

Variable 

Argument 

Variable 

Base 

Variable 

Attribute 

Type S T xith format L 

Level i i  i or <i 

Dimension undimensioned undimensioned undimensioned 

Dimension n dimension n Undimensioned or 

dimension n 

  

When the value of the argument variable matches the line number « n » in its format, the resulting variable takes the value n. 

Comments : 
1) The format of the argument variable should contain only unique values (no sub-totals), otherwise there could be 

inadequate résults. 
2) Of course, it is useful to give a format to the resulting variable, with the codes 1 to n in lines 1 to n, and by copying 

the labels of the argument variable. 
3) Using TmutS allows to work on a Single variable rather on a Text variable, which presents huge advantages : sub-totals 

are easier to build in the format, recoding functions are easier and numerous, etc. Hence, it is highly recommended to 
use it, as long as the use of the text variable is not limited to a single tabulation, without any recoding. 

 

CPL function (procedure) 

A CPL function is a procedure written in the CPL (Cotab Procedural Language) language. This language allows you to perform all sorts 

of arithmetical, logical, and test operations including iterative loops See Procedures. 

Note: CPL function must not be assigned to a dimensioned variable. 
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External Tables 

Concept 

Instead of obtaining data directly from a data file, a variable can be configured to obtain it from an External Table. External Tables 

are single-record type ASCII files in standard or CSV format. 

For standard formatted files the records must have a fixed record length. 

For CSV formatted files, the field delimiter (space, tab, or ; (semi-colon) is set in the File>Properties menu 

Each case in the study will be associated with a record in the external table by means of an index key. 

You configure a variable to obtain its data from an external table by means of the Import function. There is no limit on the number of 

variables that an external table can support. 

The first step is to create a link, by specifying the external table and index keys. 

To create a link 

1. Select the Tools>External Table menu. 

2. Click on the New Std (standard) or the New CSV button as required. The link number is automatically created. 

3. Specify the data file to be used as an external table. 

4. In Index Key table, for each index key, specify the positioning of the data field in the external table (From/To for a standard 
ASCII file, and Field no. for a CSV file) and select its associated variable in the study from the drop-down list. 

Note: The variable type must be Text, and it can be dimensioned. If several keys are dimensioned for the same table, they 
must all have the same dimension. 

To modify external links 

1. Select the Tools>External Table menu. 

2. Select the desired link number in the Import Link drop-down list. 

3. In the Index Key table, make any necessary changes. See Step 4, creating a link above. 

To delete a link 

1. Select the Tools>External Table menu. 

2. Select the desired link number in the Import Link drop-down list. 

3. Click on the Suppress button. 

Reading data 

You read data from an external table into a variable by means of the Import or ImportCSV function. These functions are similar to 

the Input functions except that they access external tables instead of the main data file. 

If one of the link keys is dimensioned, each case in the data file will be associated with several records (not one record) in the 

external table. The number of associated records will equal the dimension of the link key. 

Bases 

This "Base" field for a variable in the Variables Dictionary may be used to reference an existing logical variable positioned earlier in 

the list. 

When a variable is thus conditioned by a "Base" variable: 

• The function will not be applied to the variable if the base logical variable has the value "false". 

• The variable will be automatically filtered according to this Base when it appears in any table. 

The logical variable specified in the Base field may be dimensioned, but only if the calling variable (or an argument variable in some 

cases, see the Limitations tables) bears the same dimension. 
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Notes 

• For än Input or InputCSV function, the base will not be taken into account at the time that it  ; it will be executed even if 
the logical base variable has the value "false". 

• The base will only be taken into account (and the value of the variable set to MISSING if the logical variable has the value 
"false) after all the variables have been computed i.e. at the moment that control is passed to the calling application 
(tables, export etc.) 

• A variable possessing an Input or InputCSV function may therefore have a value other than MISSING at the moment that all 
the other variables are calculated, and yet end up with the value MISSING. 
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Execution 

General 

Variables are computed sequentially, in first to last order, whatever be their level or type, with the following conditions applying: 

• Input functions are executed first, after having read a complete data record from the input file. 

• The other functions are executed in a 2nd pass (when all the data records for the case have been processed as above). 

• The Rank function is executed last, since all variables have to have been processed before VoxcTab can decided if a case 
currently being handled will be accepted. Hence, a variable created with the Rank function must never be used as an 
argument to a function used in another variable. 

• For a study with levels, functions are executed level by level. This means that for a case at level i, only functions relating to 
resulting variables at level i will be executed. 

Processing of missing values (NA) 

During the variables creation phase, a variable is classified Missing if it does not have a value, or if its value is incompatible with its 

type (for example, a letter in a Single type variable). This applies regardless of the values specified in the Format attached to the 

variable, and during all other phases such as creation of tables, exportation etc. 

This definition changes for Single, Multiple or Text variables which have a Format: in fact, in tables it is normal to expect that all 

cases which do not belong to any of the formatted categories be grouped into the N option line (No Response). The procedure is as 

follows: 

After all variables have been calculated for a case, and before handing control over to the program being executed (tables, 

weighting, exportation etc.), for all variables which have a Format, the program verifies that their values correspond to their Format 

definitions (i.e. values or value ranges). Whenever value does not correspond, the variable in question is classified as Missing. 

For example, take a variable X that has a Format comprising values 1 to 10. If the variable takes on the value 99, this value will be 

available to a variable Y which is based on variable X; however, it will be replaced by Missing when the set of variables is passed to 

the program which calls them. Hence, this value of 99 will not be visible in Preview, but can be used in the construction of variable Y. 

Thanks to this procedure, in tables, the N option in templates encompasses all cases that are not catered for in the Format. 

In summary, the classification as Missing of a value not prescribed in a variable's Format takes place after all the variables have been 

calculated for a case; and remains so for all programs: preview, frequency table, export, weighting, and tables. 

Process 

Study without levels, and single data record per case 

1. Reads a record 

2. Executes all input functions 

3. Executes all other functions, according to their bases 

4. Executes the Rank function 

5. Applies the Base to variables using an input function. 

6. Verifies the values of all variables possessing a Format, and sets to MISSING all those whose value does not conform to the 
format. 

7. Sends the case to the module being run (tables, weighting etc.) provided any universe defined in the Study Structure has 
been verified. 

8. Repeats from Step 1 until end of the file has been reached. 

 

Study without levels with multiple data records 

1. Reads a record 

2. Executes all input functions for the record. 

3. Repeats from Step 1 until all of the records  for the current case have been processed. 

4. Executes all other functions, according to their bases 
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5. Executes the Rank function 

6. Applies the Base to variables using an input function. 

7. Verifies the values of all variables possessing a Format, and sets to MISSING all those whose value does not conform to the 
format. 

8. Sends the case to the module being run (tables, weighting etc.) provided any universe defined in the Study Structure has 
been verified. 

9. Repeats from Step 1 until end of the file has been reached. 

Study with levels 

1. Reads a record 

2. Executes all input functions for the record. 

3. Repeats from Step 1 until all of the records  for the current family case have been processed. A family is defined as a case 
at Level 1 and all its dependents. 

4. Executes all other functions, according to their bases, in sequential order. For a variable at Level 1, since there is only one 
case per family, each function will only be executed once. For a variable at a lower level (higher level number (2, 3 etc.) 
since there can be several cases at this level, the function will be executed for each case at this level, before proceeding to 
the next variable. 

5. Executes the Rank function for each case. 

6. Applies the Base to variables using an input function. 

7. Verifies the values of all variables possessing a Format, and sets to MISSING all those whose value does not conform to the 
format. 

8. Sends the Family to the module being run (tables, weighting etc.). VoxcoTab sends the cases one at a time, starting with 
the case at level one, followed by each dependent at the next level in the dependence tree etc. This procedure ensures that 
each parent will always precede its dependents, and that cases from different dependence chains will never be found 
together i.e. cousins will never be found together. 

9. Repeat from Step 1 until end of the file has been reached. 

Special Case for variables at Level 0 

In a study with levels, variables usually belong to one of the levels defined in the Study Structure; however, they can also belong to 

level 0. By convention, a variable belonging to level 0 is considered to belong to all levels, meaning that it will be computed for each 

case in every level. 

Generally, level 0 is used to define level identifiers such as sequence numbers computed with the Rank function, or to explicitly 

register the case's level (for inclusion in an exported file, for example). 

Execution of multiple files 

All VoxcoTab operations (tables, exportations etc) can be performed on one or several files (several survey waves, for example). The 

files are processed sequentially as one file, and all you have to do is name them all in the file specification dialog window concerned. 

External tables 

Every time an import function is executed, VoxcoTab looks in the specified external table for the record which matches the assigned 

index keys, given their current value (if more than one record matches, the first one will be picked). 

The variable to be imported is read from this record. It is possible, therefore, that for the same individual, 2 variables using the 

import function to access the same external table might obtain data from 2 different records. This could happen if the value of the 

index key variable is changed between reading the first and the second variable (through a procedure). 

Note: If the index key is dimensioned, the variables read through importation from a corresponding external table must also be 

dimensioned; each occurrence is read from the external record which corresponds to the occurrence of the matching index of the 

key. 
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Cache file 

This option is designed to speed up the execution of resource intensive studies, for example comprising tens of thousands of cases. 

In fact, running any application (tables, exportation etc.) consists, for each case, of first calculating its set of variables and secondly 

executing the application (tables, exportation etc.); this process is repeated for each case in the data file. 

Sometimes the first phase (calculation of variables) can take much longer than the second (if there are many variables, or if 

procedures for calculating variables are particularly complex). When executing several table commands, one after the other, this can 

be costly in time since the variables calculation is repeated each time. 

When you use the Cache option (Tools>Properties>Use Cache) the results of variable calculation when executing the first set of 

cases will be written to the Cache file. When the next command is executed (tables, exportation etc.) the program will automatically 

read the Cache file instead of reading the data file and recalculating all the variables again. 

The Cache file will  remain valid so long as the variables dictionary has not been modified. If the variables dictionary is modified (new 

variable, change made to a function etc.) the Cache file will be automatically erased and re-built. 

Warning: Neither the Bases of a variable, nor the use of Universes in study structures, are taken into account to assess whether the 
variables dictionary has been modified. In this situation you must erase/reset the Cache file yourself, using the Tools>Reset Cache 
command. 

Execution of several data files. Whether the files are called in several consecutive executions or in a single execution, the Cache 

file contains a sub-file for each data file. Hence, in a subsequent execution, the program will access the appropriate cache file(s). 

Multiple wave study. When executing a command comprising several waves, the program will use existing cache sub-files, and 

create a new one for each new wave. 
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Preview 

The Preview command, accessed through the Tools>Preview menu or the Execute button  in the Toolbar starts reading the 

source data file, and calculates the variables for the first case. The values of these variables are displayed in the Preview column in 

the Variables screen. When you click on the header of the Preview column the next case will be read, calculated and displayed. 

 

Comment:When working with a dimensioned variable, if you click on the + sign on the left of the dimension field or press the space 

bar when it is selected, it will be expanded to display all of its occurrences. 
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Frequency Tables 

You can quickly display a variable's frequency distribution, regardless of its type. 

To obtain frequency distributions 

Do one of the following: 

• Select Utilities>Frequency table in the main menu, and then choose the variables you are interested in. 

• Right-click on a variable in the variables list, and select Frequency table in the pop-up menu. 

Once you have chosen the source data file when prompted, you will be presented with the frequency distribution (s) of the chosen 

variable(s). 

Each value encountered in the variable is shown in the left-hand column together with its frequency in the right-hand column, 

regardless of any categories which may have been defined in the variable's Format. However, when the variable does have a Format, 

any values which are not defined in the format are categorized as NA (Missing), and will not appear in the displayed list. 

 

For Quantity variables, the mean, standard deviation, median and  1st and 3rd quartiles are shown as well. 



 

69 

 

Templates 

Overview - Templates 

In tables, each variable invoked is associated with a Template, whose role is to define which Options 

(counts, statistics etc.) of the variable are to be applied/displayed. 

These Template Options are chosen out of the following list (the default labels describing them can be 

customized in the Tools>Preferences menu): 

  Option Description 

T Total The total  for the variable taking into account any base that might be 

associated with it 

N No response Corresponds to the number of MISSING values for the variable, as 

defined in the description of Variable Attributes. This applies to: 

• Variables without a Format specification: all true Missing values 
are included. 

• Variables with a Format specification: all values not described 
in the category values or value ranges.   

D Distribution Refers to the list of categories in the variable's Format. This option 

requires that the variable has a Format. 

A A least one 

response 

The total number of respondents to the variable. Hence, the opposite of 

the N option (no response). 

C Sum The sum of a variable's values (real numbers for Simple or Quantity type 

variables,  or the value that might be assigned to the variable's 

categories in an associated Format. 

M Mean The mean of the variable's values which qualify for the Sum (see above). 

Md Median The median of the variable's values which qualify for the Sum (see 

above). 

Mi Minimum The minimum value of the variable which qualifies for the Sum. 

Ma Maximum The maximum value of the variable which qualifies for the Sum. 

NB Average number 

of responses 

Average number of responses for a multiple variable 

NT Number of 

responses 

The number of responses for a multiple variable 

LO List of 

occurrences 

For a dimensioned variable, this list allows each occurrence to be 

customized, by editing them in various positions (rows, columns or 

pages). 

W Weighting   

  

A template comprises one or more of these Options, each comprising several attributes or settings. 

The Check button  in the Toolbar allows you to check that there are no errors in the variables or 

templates. 
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Managing Templates 

The Templates window is brought into view when you click on the Templates tab at the bottom-left of the 

screen. It is divided into 2 panes. 

• The left-hand pane displays the list of the current study's templates to which you can add and 
delete. 

• The right-hand pane shows the attributes of the template currently selected in the left-hand 
pane. 

 

 You can perform the following actions in the templates list when a template row is selected (in the left-

hand pane): 

Operation Main Menu Mouse 

click 

Toolbar 

Add (Insert) 

Note: Specify a template number 

(1 to 999) and title 

Edit>Insert Right-click 
 

Delete Edit>Delete Right-click 
 

Duplicate Edit>Duplicate Right-click 
 

Rename   Right-click, 

Double-click 

  

Import 

Note: If the template number 

already exists, your are prompted 

to change its number or substitute 

the existing template. 

  

  Right-click   

Copy from another study Edit>Copy from the source 

study 

Edit>Paste into the 

current study 

Right-click 
   

  

Default template: One of templates in the list must be chosen as the default template, by clicking in the 

box situated to the left of its title. This will be the one applied to variables to which no template has been 

specified. 

Note: When the Title field is selected, with a right-click you can copy, paste or clear the title. 
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Template Options 

In the right-hand pane, when you have selected a template in the list, you can add as many rows as you 

wish; each row representing an Option.Managing Options 

When a row is selected, a right-click provides access to standard edit functions: insert, delete, duplicate, 

copy/paste (rows), and font selection. 

Operation Main Menu Mouse click Keyboard Toolbar 

Add (Insert) Edit>Insert Right-click   
 

Delete Edit>Delete Right-click   
 

Duplicate Edit>Duplicate Right-click   
 

Fonts   Right-click     

Copy/Paste (rows) Edit>Copy 

Edit>Paste 

Right-click   
   

Move row Edit>Move Up 

Edit>Move Down 

  Ctrl+Up arrow 

Ctrl+Down 

arrow 

 

Managing Option fields 

The fields, and edit methods for defining each option are: 

Field Comment Mouse clicks Keyboard 

Option See Templates Overview Double-click in 

the field, or click 

on the down-

arrow on the right 

of the field to 

access the Option 

list 

Type the 

Option's first 

letter 

(uppercase) 

% Basis You can designate an existing Option (by 

specifying its line number) which is to be 

used as the base in calculating the 

percentage.The base option must only be of 

type T, C, NT or A. 

Note: A % Basis cannot be used for Option 

types M, NB, Mi and Ma. 

    

Suppress 

Weighting 

With this checkbox selected, corresponding 

items will not be subjected to any weighting. 

    

Label This is the Label that will appear in tables 

using this Option, except for the Options D 

and LO. 

Note: The default Label, unless you modify 

it, is taken from the Label as set in 

Preferences. 

Double-click in 

the field to edit 

the Label. 

The font settings 

for one or more 

selected Labels 

are accessed with 

Type in the field 

to overwrite its 

contents 



 

72 

 

a right-click of the 

mouse. 

Decimals The number of to be displayed in 

percentages or means (depending on the 

option), and for Sums, Minimum, Maximum 

and Medians 

    

Place Note: This field is reserved for future use     

Hide With this checkbox selected, the 

corresponding item will not be displayed. It 

will simply be used in the calculation of other 

items. 

    

  

Notes: 

• Copy, Paste and Clear functions apply to one or more cells selected in a column. 

• The Font settings for one or more selected Labels are accessed with a right-click of the mouse. 

• Decimals with option C apply both for Sums and for percentages if required. 
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Tables 

Managing Table Requests 

The Tables window is brought into view when you click on the Tables tab at the bottom-left of the screen. 

It is divided into 2 panes. 

• The left-hand pane displays the list of the current study's Folders to which you can add and 
delete. 

• The right-hand pane shows the Table Requests contained in the Folder currently selected in the 
left-hand pane. You can add any number of requests to this table. 

 

In both panes, you Insert (add), Delete, Duplicate, Import, Copy and Paste Folders and Requests 

respectively. Import, Copy and Paste functions also work from one study to another. Both for Folders and 

Requests, the only items to edit are their Titles. 

The Check icon  in the toolbar tests the currently selected table request, or, if a folder is selected, all 

the table requests in that folder. 
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Table Request 

The Table Request configuration window is displayed when you double-click on a Table Request (in the 

Requests pane). Note that the toolbar has new buttons: 

 

Note: Table Request buttons are added on the right-hand side of the Toolbar. 

 

Table Request configuration settings 

Setting Description 

Weighting An undimensioned quantity variable 

Universe 

(Filter) 

An expression using logical variables exclusively connected with the Boolean operators 

AND, OR and EX (exclusive). If the result of this expression is TRUE, for any case, then 

that case will be included in the table. Otherwise, the case will be excluded. 

The default order of execution is from left to right, but you can use parentheses to 

specify priority amongst the operators. 

If using dimensioned variables, they must all have the same dimension. 

Operator rules 

Expression Result 

A AND B TRUE  if the logical variables A and B are both TRUE 

A OR B TRUE if at least one of the logical variables A and B is TRUE 

A XOR B TRUE provided that only one of the logical variables A and B is 

TRUE. 

Example of a universe: (Q18 AND MALE) OR (Q25 AND FEMALE) 

Table unit windows: You can select any of the three windows (Pages, Stubs or Banners) by clicking 

on it. Its title will have * appended, to indicate that it is the one currently selected. 



 

75 

 

You can perform the following actions when a row is selected in the Banners and Stubs windows: 

 

Operation Main Menu Mouse click Toolbar 

Add (Insert) Edit>Insert Right-click 
 

Delete Edit>Delete Right-click 
 

Duplicate Edit>Duplicate Right-click 
 

Copy/Paste Edit>Copy 

Edit>Paste 

Right-click 
   

Move a row Edit>Move Up 

Edit>Move Down 

Ctrl+Up arrow 

Ctrl+Down arrow 
 

  

Pages A First Stage and/or Second Stage variable within whose categories the Stub and 

Banner will be crossed. 

If a Second Stage variable is specified, it will be crossed with the First Stage variable 

i.e. each of its categories will be broken out within each category of the First Stage 

variable. 

See Table request element - attributes 

Stubs Any number of variables to be used for creating rows in the table. 

Any variable may set to Stage 1 or Stage 2. However, the first one must set to Stage 1. 

A variable set to Stage 2 will be crossed with the Stage 1 variable which comes before 

it. 

See Table request element - attributes 

Banners Any number of variables to be used for creating columns in the table. 

Any variable may set to Stage 1 or Stage 2. However, the first one must set to Stage 1. 

A variable set to Stage 2 will be crossed with the Stage 1 variable which comes before 

it. 

See Table request element - attributes 
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About Stages and cross-tabulation 

Stages is a feature which enables you to add a further breakdown dimension to a cross-tabulation. 

Any variable selected in a table request can be specified as Stage 1 or Stage 2. A Stage 2 variable (which 

must be preceded by a Stage 1 variable) will be broken down (within its own Banner or Stub) by each 

category of the Stage 1 variable which precedes it. 

When you add a variable to a Stub or Banner, you can add it as a Stage 1 or Stage 2 variable. Stage 2 

variables are easy to identify because they are indented in the list. You can change a variable from Stage 

1 to Stage 2 and vice-versa by means of the Ctrl+Right/Left arrow keys. 

Example: In the screen-shot above,  the Stage 2 variables OCC and SEX will be broken down in the Stub 

by the Stage 1 variable MSIZE. The process is a cross-tabulation in which the category combinations are 

reflected in the Stub. 

The final table comprises a cross-tabulation of all the Page variables, Stub variables and Banner variables. 

To execute a request 

To execute a request, click on the Execute button in the toolbar . 

To return to the Requests folder 

To return to the Requests folder, click on the Return button in the toolbar . 
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Table Request variables - attributes 

Each unit (row) in a table request consists of a selected variable together with several attributes: 

 

Variable 

A variable used in the definition of a Page, Stub or Banner can be of any type (single, multiple, text, 

quantity or logical) or level (if the study has levels), and they may be dimensioned. 

If the only dimensioned variables are in a Stub (and they are not expanded), they can have different 

dimensions. An exception to this however, is for a pair of Stage 1 and Stage 2 variables; they cannot have 

different dimensions. The same applies to dimensioned variables in a banner i.e. provided there are no 

dimensioned variables in the Page, Stub or Universe. 

In all other situations, all un-expanded dimensioned variables specified in the table request must have 

same dimensions. 

To add a new variable 

To add a new variable, or assign a new variable, click on the button on the right of the field. This brings 

up the Variables Selection List (the Variables Tab in the Variables/Expressions window): 

 

Button Description 

Set 

variable 

Sets the chosen variable (as a 1st Stage variable) for the 

currently selected unit (line) 

Add 1st 

stage 

Add 2nd 

stage 

Adds the chosen variable(s) as 1st or 2nd Stage variables 

after the currently selected unit (line) 

  

 Note: 

• To assist in choosing your variable, you can narrow down the variables by Type or show variables 
in alphabetical order.  Click in the Name or Type column header. 
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• You can display all the occurrences of a dimensioned variable by clicking on its + sign prefix. This 
allows you to choose one or more of them. 

To filter (customize) the selection of a variable's categories 

When you have a variable selected (whether in the Pages, Stubs or Banners area), a right-click provides 

access to the Filter Editor (in addition to Copy, Paste and Reset functions). The Filter Editor allows you to 

include or exclude specific category codes for the variable. Note: It only applies to variables using the 

template option D (Distribution). 

  

The full set of the variable's formatted category codes are initially displayed in the left-hand list. The codes 

that you wish to include or exclude, you then move to the right-hand list by using the arrow buttons 

between the lists. The radio buttons Include/Exclude selection determine whether the codes in the right-

hand list will be included or excluded respectively. 

This option operates on display only,  which means that you can modify it after a table has been executed. 

It applies only to the situation in which it is specified i.e. even if the same variable appears elsewhere in 

the same table, it will not be affected by this filter. 

Expand 

A dimensioned variable which has been selected globally can be expanded by clicking on its Expand 

checkbox. The result is equivalent to having selected each occurrence individually. Hence, the constraints 

on using dimensioned variables described above do not apply when the variable is Expanded. 
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Template 

If no template is assigned, the default template will be used. 

To assign a template to a variable 

• Type the template number in the variable's template field, or 

• Select a template from the list that appears when you double-click on the variable's template 
field, or simply click on the button to the right of it. 

Note: A template assigned to a logical variable can only contain the following options: 

Option Description 

T Total 

A Value TRUE 

N Value FALSE 

LO Applies to a list of occurrences (dimensioned variable) 

Weighting - W option 

This options enables you to create tables using several weighting variables. It can be applied to pages, 

columns or rows in the table. 

Use of the W option is equivalent to specifying a weighting variable in the table request. 

Comments: 

1. Regardless of whether the W option is applied to a rows, columns or pages, it must be 
accompanied by another option - at the 1st stage if W is at the 2nd stage, and at the 2nd 
stage if W s at the 1st stage. Hence, if there is only one stage, W should not be used. 

2. If there are several W options in the table, only one is applied in each component table, 
in the following priority order: column (stage 2, if not stage 1); if not, in rows; if not, in 
pages; if not, in the table's weighing field. 

Percentages (%) 

This field is generally not used. It allows you to modify the definition of the base for percentages 

contained within the template associated with the variable. If you enter a number, the base for 

percentages will be taken from the variable/template pair bearing this number. This enables you to apply 

a percentage base which is totally independent of the variable using it. 

Nevertheless, certain restrictions need to be respected: 

When a variable A references, for a percentage base, a line in the table using variable B, then... 

• If variable A is Stage 1, then variable B must also be Stage 1. 

• If variable A is Stage 2, either variable B is Stage 2 in the same group i.e. they must both 
depend on the same Stage 1 variable, or variable B is Stage1, hence in a group other than A. 

Moreover, in the template associated with variable A, if the percentage base is line j, then line j of the 

template associated with variable B must be of type T,C or A only. 

Generally speaking, this Percentages field is used simply to refer to a line containing a logical variable 

associated with a template comprising a single option. Hence its use is very straightforward. 

Note concerning percentages: Percentages are always computed at the last Stage. This means that 

when there are 2 stages, any percentages requested with the variable at the 1st stage are not taken into 

account. Similarly, a request for a different base (see above) will not be taken into account if the line 

referenced is Stage 1 and if it is followed by a 2nd stage. 
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Page Break 

When this checkbox is selected, a page break will be included in the output before the tables using this 

variable. This applies for PDF and Excel-XML output. 

You can select/deselect the page break option for several variable at a time in a table request. Simply 

select the variables, and use the Check All option available with a right-click of the mouse.    

Note: Copy, Paste and Clear functions can be used on multiple fields in the Variable and Template 

columns. 
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Execution of a table request 

Constraints on a table request 

When you click on the Check button  or the table request Execute button , VoxcoTab checks the 

Variables and Templates specified in the table request. If errors are encountered they are reported, and 

the execution does not take place. Checks include the following: 

• Referenced variables must exist. 

• Weighting variables must be Quantity type, and undimensioned. 

• Universe (filter) variables must be Logical type. 

• Page, Stub or Banner variables whose template includes a D option (distribution) must have a 
Format. 

• The options C, M, Mi, Ma ans Md in a template imply that the variable applying them is Single or 
Quantity type. Or, if they are Multiple or Text type, their categories must have been assigned 
values in their corresponding Formats. 

• The W opton in a template implies that the calling variable is of Quantity type, and that it is 
associated at the 1st stage (or 2nd stage, depending on the circumstances) with another option 
(other than W). 

• The NB and NT options imply that the variable calling it is Multiple type. 

• The LO option implies that the variable calling it is dimensioned. 

• Unexpanded dimensioned variables may be used in a Page, Stub, Banner or Universe, provided 
they have the same dimension. However, if the only dimensioned variables are in a Stub (and 
they are not expanded), they may have different dimensions. An exception to this however, is 
for a pair of Stage 1 and Stage 2 variables; they must not have different dimensions. The same 
applies to dimensioned variables in a Banner i.e. provided there are no dimensioned variables in 
the Page, Stub or Universe. In all other situations, all un-expanded dimensioned variables 
specified in the table request must have the same dimensions. 

Errors are displayed in the new window below the requests. When you click on the error message, the 

request line at fault is highlighted in red. 

Execution. 

If no errors are detected, the data file is read case-by-case. Provided that the conditions for inclusion in 

the tables are satisfied i.e. compliance with the expression used in the Universe (filter), the data are 

broken out into a table comprising a set of component tables each of which is defined by a Page variable 

(or pair of them if there is a 2nd Stage variable), a Stub variable (or pair of them if there is a 2nd Stage 

variable), and a Banner variable (or pair of them if there is a 2nd Stage variable), taking into account the 

various Options and settings of their associated templates. 

The breakdown in a component table depends, however, on the bases that might be applied to the Stub, 

Banner or Page variables according to the following rules: 

• A base assigned to a cross-tabulation variable (Stub, Banner or Page) will be taken into account. 
There are, however, two exceptions: 

o The dimension of the base is greater than the dimension of the variable to which it is 
applied; which is to say that the base is dimensioned while the variable is undimensioned. 
This can occur when using the NbVal function, for example. 

o The level of the base is greater that the level of the variable. 

• If a base applies, and if its value is FALSE, the component table will not include the case. 

If there is Weighting specified, a MISSING value in the referenced weighting variable limits the case from 

being counted in a table cell to when it is set to "unweighted" i.e. for those whose template (Stubs, 

Banners or Pages) includes the "unweighted" option. 
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Component tables 

The set of component tables (which make up a complete table) is determined by the crossing of Page, 

Banner and Stub Chains. 

Stage 1 variables only: When variables are Stage 1 only, a Chain is the same as an Element, which is 

the union of a Variable and an Option in its associated Template. There are as many Chains as there are 

Variable/Option combinations. 

Stage 1 and Stage 2 variables: When there are Stage 1 and Stage 2 variables involved (in a Page, 

Banner or Stub), the result is equivalent to a cross-tab within the Page. Banner or Stub. Hence, there is a 

Chain for each Stage 2 Element paired with each of its Stage 1 Elements. 

Example without Stages: 

  Variable Template 

Options 

Element/Chain 

Page 

Variable 

SEX T (Total) 

D 

(Distribution) 

SEX.Total 

SEX.Distribution 

Banner 

Variable 

REG T (Total) 

D 

(Distribution) 

REG.Total 

REG.Distribution 

Stub 

Variables 

Q5 T (Total) 

D 

(Distribution) 

N (No 

Response) 

Q5.Total 

Q5.Distribution 

Q5.No Response 

Q6 T (Total) 

D 

(Distribution) 

N (No 

Response) 

Q6.Total 

Q6.Distribution 

Q6.No Response 

The total number of component tables will be 24 i.e. the product of the Page, Banner and Stub 

Element/Chains. 

Example with Stages 

    Variable Template 

Options 

Element Chain 

Page Variable SEX T (Total) 

D 

(Distribution) 

SEX.Total 

SEX.Distribution 

Banner Variable REG T (Total) 

D 

(Distribution) 

REG.Total 

REG.Distribution 

Stub 

Variables 

Stage 1 Q5 T (Total) 

D 

(Distribution) 

N (No 

Response) 

Q5.Total 

Q5.Distribution 

Q5.No 

Response 

Q5.Total-Q6.Total 

Q5.Total-Q6.Distribution 

Q5.Total-Q6.No 

Response 

Q5.Distribution-Q6.Total 

Q5.Distribution-

Q6.Distribution 

Stage 2 Q6 T (Total) 

D 

(Distribution) 

Q6.Total 

Q6.Distribution 
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N (No 

Response) 

Q6.No 

Response 

Q5.Distribution-Q6.No 

Response 

Q5.No Response-

Q6.Total 

Q5.No Response-

Q6.Distribution 

Q5.No Response-Q6.No 

Response 

The total number of component tables will be 36 i.e. the product of the Page, Banner and Stub 

Element/Chains. 

Component table breakdowns 

Non-quantitative component table: None of the options C, M, Mi, Ma, Md, NT or NB appear in any of 

the chains. A case (optionally weighted) will be broken down into all the cells of the table for which the 

case applies i.e. as defined by the crossing of all the pages, columns and rows, and for which any 

associated bases are true. 

Quantitative component table: At least the one of the options C, M, Mi, Ma, Md, NT or NB appears in 

one of the chains. In this case, the value of the corresponding variable will be broken down into all cells as 

defined above. 

• C option. The value of the corresponding variable is simply summed (multiplied by a weighting 
factor, if applicable) in the cells. 

• M option. The value of the variable is summed (weighted if applicable), the squared values are 
summed (weighted if applicable), and the number of cases (weighted if applicable) is computed 
for eventual calculation of the mean and standard deviation. 

• Md option. All the values of the variable are stored in each cell of the table, in order to compute 
the median. 

• Mi or Ma option. The minimum or maximum (excluding missing values) is displayed in each cell 
that applies. 

• NT option. The number of values of the corresponding variable are cumulated (weighted if 
applicable) in the cells. 

• NB option. The number of values (weighted if applicable) of the associated multiple variable is 
summed for calculation of the mean. 

Component table with several quantities: The options C, M, Mi, Ma, Md, NT or NB appear more than 

once in the six possible elements constituting a component table. Since a cell in a component table can 

only involve a single quantity, it is chosen in the following priority order: columns, by default in rows, by 

default in pages, and in each of the dimensions, firstly at the 2nd stage, if it exists, if not by the 1st stage. 

Dimensioned component table: This occurs where at least one of the variables is dimensioned and 

unexpanded i.e. a universe or chain variable. 

In this case, let n be the number of occurrences of the dimensioned variable (remembering if there are 

several dimensioned variables constituting a component table, they must have the same dimension). Each 

case will be broken down n times in the component table successively for occurrence 1, occurrence 2 etc. 

The LO option in a template enables the breakdown and display of each occurrence. 

Studies with Levels 

The breakdown depends both on the levels defined for the study, and the different variables specified for 

the table. The level of a component table, as defined by its weighting, universe (filter), page, row and 

column variables, is equal to the lowest level encountered in this combination (i.e. the level bearing the 

highest number). 

The general rule is that a component table at level j is populated by the data gathered at level j, but this 

does not prevent the inclusion of data from a higher level (i.e. from a level bearing a small number). 
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Example: 

Assume that we have a study with the following variables: 

Level Variables 

Level 1 

(Households) 

REGION, INCOME 

Level 2 

(Individuals) 

MEMBER, SEX, AGE 

Level 3 (Trips) TRIP, SERVICES, 

SATISFACTION 

and that we issue the following Table Request: 

 

The component table (REGION, SEX-AGE, MEMBER) will contain Members 

The component tables (REGION, SEX-AGE, TRIP), (REGION, SEX-AGE, SERVICES), (REGION, SEX-AGE, 

SATISFACTION) will contain Trips. 
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Percentages (example) 

This example is based on the following Template and Table Request: 

Template 

 

Table Request 

 

Column Percentages 

Q1A: The columns Total, No Response and At Least One Response use the column Total of Q1A as the 

base for percentages. The columns for the distribution (categories) of Q1A use as the base for their 

percentages the column At Least One Response for Q1A. 

Q3B1: All the columns use the column Q4A as the base for their percentages. 

SHOP: The columns Total, No Response and At Least One Response use the Total Column of Q1A as the 

base for percentages. The columns for the distribution of SHOP use as the base for their percentages the 

column At Least One Response for Q1A. 

Row Percentages 

STATE: The rows Total, No Response and At Least One Response use the row Total of STATE as the base 

for percentages. The rows for the distribution (categories) of STATE use as the base for their percentages 

the column At Least One Response for STATE. 

TYPE: All the rows requiring a percentage, i.e. Total, No Response, At Least One Response (TRUE), and 

Distribution, use the row SHOP as the base for the percentages. This applies to all the categories 

belonging to SEX i.e. Total, Male, Female, No Response, At Least One Response, and Unweighted Total. 

SHOP: The percentage base is the row for SHOP itself. 
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Presentation of Results 

Preview 

The Preview button  in the Toolbar displays a Preview of the table. It also serves to toggle back and 

forth between the Table Preview and the Table Request that produces it. 

If Page variables have been specified in the Table Request, you can select any page from the Page drop-

down menu in the upper part of the window. 

You can re-size column widths and row heights by click-dragging on any cell border. 

 

  

A right-click in the table window pops-up a menu from which you can Execute a Table Request, access 

Table and Page Settings, view the Page Index, perform a Gamma Test, and Refresh the screen. 
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Table Display Settings 

The Table Display Settings window is accessed through its button  in the toolbar: 

 

The various settings presented in this window, which allow you to customize the table display, apply 

equally to screen display, printed display, or display exported to Excel. 

The combination of settings in this window can be given a name and saved as a Style (see the Save As 

button above). You can Load the settings of any existing Style (see the Load button above). 

Note: In the Tools>Table/Page Settings menu, you can add, delete and edit Table Settings Styles. 

Stubs 

The settings for Stubs are presented in the upper-left area of the window: 

Settin

g 

Description 

1st 

and 

2nd 

Stage 

Style 

Show Titles: This checkbox allows you to show/hide the variable titles. 

: These buttons access dialog windows where you can set Font and Background 

colour for Titles 

Show Labels: This checkbox allows you to show/hide category labels 

: This button accesses the dialog window where you can set the Background colour for 

category labels 

Note: Font style for a category label is set in the variable's Format. 

Border

s 

External border applies to the Stub variable's title. 

Cell separator applies to the cell borders. 
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Borders settings are: thick, thin or no border, and you can set their colours as well. 

Line 

Indent 

Indentation of Titles and Labels in number of characters. 

Displa

y 

Empty 

Lines 

This checkbox allows you to display empty rows. When not checked, empty rows are not 

displayed, and a table consisting of empty rows will not be displayed either. 

Row 

Rankin

g 

You can sort rows in ascending or descending order. The sort is applied only within the 

same Chain at the last stage of a  D (Distribution) or LO (List of Occurrences) Option. 

The sort is performed always on the values in the 1st column; this will be the counts, or 

means if applicable. 

When there is a Distribution, the level of indentation of category labels in the Format will be 

used as a further primary sort key. 

Example: 

Banners 

The settings for Banners are presented in the upper-right area of the window: 

Setting Description 

1st and 2nd 

Stage Style 

Show Titles: Allows you to show/hide the variable titles. 

: For setting Font and Background colour for Titles 

Show Labels: Allow you to show/hide category labels 

: For setting the Background colour for category labels 

Note: Font style for a category label is set in the variable's Format. 

Borders External border applies to the Banner variable's title. 

Cell separator applies to the cell borders. 
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Borders can be thick, thin or no border, and you can set their colours as well. 

Justify Justification applies to Banner Titles and Labels as a whole. You can justify them 

both vertically and horizontally. 

Display Empty 

Columns 

This checkbox allows you to display empty Columns. When not checked, empty 

Columns are not displayed, and a table consisting of empty Columns will not be 

displayed either. 

Column 

Ranking 

You can sort columns in ascending or descending order. The sort is applied only 

within the same Chain at the last stage of a  D (Distribution) or LO (List of 

Occurrences) Option. 

The sort is performed always on the values in the 1st row; this will be the counts, or 

means if applicable. 

Counts 

The settings for Counts are presented in the lower-left area of the window: 

Setting Description 

Tests The choice is Chi2 Test or Proportion Tests. 

Test are performed on each table defined by the Stub and Banner variables used in the 

last stage. It is assumed that the last stage variables in the Stub and Banner are using 

a Template which includes the T (Total) Option, or by default the A (Respondents) 

Option i.e. that there is both a Total row and Total column. 

If the table contains both weighted and unweighted parts, tests are always conducted 

separately for each part. Hence, if the table presents a weighted distribution for a 

variable, there must be a weighted total row (specified with a T or A option in the 

Template). 

These tests make the assumption that the table does not include any M (mean), Mi 

(minimum), Ma (Maximum), NB (average number or responses) Options. In view of the 

above, a table can include tests for some parts, and exclude tests from other parts. 

Chi2 Test 

The Chi2 test enables you determine if the count in a cell is over or under-represented. 

A count which is over-represented is indicated by "+" signs, a count which is under-

represented is indicated by "-" signs. Display of one, two, or three of these signs 

indicates a confidence level of 90%, 95% and 99% respectively. 

The Chi2 test assumes that both the Total row and Total column (corresponding to the 

T or, by default the A option in the Template) are either weighted or unweighted in the 

cell being tested. 

Proportions Test 

The Proportions test compares counts between each pair of columns (including the 

Total column if requested). Columns are labelled A, B, C etc; the Total column, if 

requested, is labelled Z. The column corresponding to the Template option A 

(respondents) is labelled Y. The test result for a cell is displayed, in the cell itself, by a 

listing of the labels of all the columns against which the test is positive. However, the 

result of the test is displayed only in the column with the highest count (except when 

comparison is against the Total column, in which case the test is displayed in the other 

column.) 

For any given column, comparison tests are made only with columns to the left of it in 

the display. 
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The Proportions test assumes that there is a Total column (Template option T, or by 

default option A, if comparison with the Total is requested) and a Total row ((Template 

option T, or by default option A) which are homogeneous i.e. both weighted or 

unweighted for the cell being tested 

Notes: 

• When there is both a weighted and unweighted Total column, they will each 
nevertheless be labelled Z (or Y) since column testing is always made against 
the only Total column which is appropriate. 

• When the table presents a weighted distribution, if the test has to be made on 
the unweighted frequencies, then there must be both a weighted T and 
unweighted T option in the Template (or by default a weighted A and 
unweighted A option). 

Confidence intervals. 

This option provides confidence intervals in each cell of a table. 

In the ‘Table Settings’ screen, the user is given the following options, in the ‘Tests’ 

area. 

In the lower-left area, CIV and CIH provide confidence intervals for vertical and 

horizontal percentages. 

In the lower-right area, CI provides the confidence interval for means. 

In both cases, the user must choose one of the options : 90, 95 or 99% (elsewhere, 

the 95% option is applied by default). 

Background 

Colour The Background Colour  button applies to cells with "counts". 

Use Background colour for Chi2 checkbox (which applies if the Chi2 test is selected) 

allows you to use colours to indicate cell significance corresponding to +++, ++, ... as 

described above. 

The  button to the right of the checkbox, allows you to select a colour for each 

significance level. 

 

Cell layout 
Note: These settings only apply to cells without Means. 

Each cell in a table has a choice of 9 available sub-cells (positions) for displaying 

Counts, Row Percentages, Column Percentages and Tests. You can "Drag and Drop" 

any item from one position to another. 
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Once you have selected an item (by clicking on it), you can: 

• Make an item invisible. When you un-check the Visible checkbox, a line will 
be drawn through the cell to indicate that its contents will not be displayed in 
the table (see above). If the item is the Chi2 test, this will suppress the signs 
+++,...but have no effect on any background colours that you may have 
specified. 

• Adjust to 100%. This option allows you ensure that the displayed 
percentages add up to 100% exactly. To make the option appear, click on a 
$H or %V cell.. 
 
The option applies only to type D templates: 

o For the %H percentages, the column variable at the last stage must be 
of type S or T. 

o For the %V percentages, the row variable at the last stage must be of 
type S or T. 

Notes: 

o The % concerned must have no decimals, otherwise this option will be 
ignored. 

o If the % is based on T, the base will consist of all simple codes in the 
variable's Format plus those in the N (No code) category, if it exists. 

o If the % is based on A, the base will consist of all simple codes in the 
variable's Format. 

The program will take the sum of the percentages described above. If the 

sum differs from 100, one or more percentages will be adjusted to make the 

sum add up to 100. 

• Set Font attributes for an item. Double-click on the cell, or click on the 

Font button  to access the Font attributes dialog window. Attributes 
include Font, size, style, colour etc. 

Display of Counts 

Points to note concerning the display of counts: 

• If the cell contains a C (Template) Option, the results will be displayed with 
the number of decimals given in the template. Note : in this case, the same 
number of decimals is used both for Sums and for percentages.  

• When you make counts invisible, the positions in the table will only contain 
percentages. If there are positions for which no percentages are requested, 
the position should be empty. To avoid this situation, by convention, counts 
will be displayed in empty cells in place of the missing percentages. This 
enables you to have tables which present in the same column: a count 
representing the base total, and percentages in the category cells. 

Threshold When Proportion tests are requested, you can choose the threshold value: 90/95, 

95/99, 90, 95 or 99%. Results will be shown in upper-case if the highest end of the 
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range satisfied, and in lower-case if the lowest end of the range is satisfied. For single 

threshold values (90 for example), the letter will be shown in upper-case. 

Display 

percent 

sign 

When this setting is checked, each percentage will be followed by the percent sign %. 

Character 

for empty 

cells 

You can specify a character to be displayed in empty cells. 
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Means 

The settings for Means are presented in the lower-right area of the window. 

Setting Description 

Means 

Tests 

If any one of the counts is less than 30, the Student's T test will be used. 

The test is performed by comparing the results in 2 columns. The columns are labelled 

A, B, C,... as in the Proportions tests, the Total column labelled Z, and the 

"respondents" column (Template Option A) labelled Y. For any given column, 

comparison tests are made only with columns to the left of it in the display. However, 

the result of the test is only displayed in the column with the highest mean (except 

when comparison is made against the Total column, in which case the test is displayed 

in the other column.) 

Background 

Colour The Background Colour  button allows you to set the background colour for cells 

with "means". This enables you to make them easy to distinguish visually from cells 

with counts. 

Cell layout 
Note: These settings apply only to cells with Means. 

Each cell in a table has a choice of 9 available sub-cells (positions) for displaying a 

Count, Mean, Standard Deviation, Standard Error and Tests. You can "Drag and Drop" 

any item from one position to another. 

 

Once you have selected an item (by clicking on it), you can: 

• Make an item invisible. When you un-check the Visible checkbox, a line will 
be drawn through the cell to indicate that its contents will not be displayed in 
the table (see above). 

• Set Font attributes for an item. Double-click on the cell, or click on the 

Font button  to access the Font attributes dialog window. Attributes 
include Font, size, style, colour etc. 
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Example of a table using Background colours 

 

 



 

95 

 

Page Settings 

The Page Settings window is accessed through its button  in the Toolbar. Note: Page Settings can be 

saved under a Stylesheet name which can be later Loaded into this window: 

 

Note: In the Tools>Table/Page Settings menu, you can add, delete and edit Page Settings Styles. 

Setting Description 

Right then down 

Down then right 

This setting allows you to determine the order in which several pages will be 

output. It applies when a table is too large to fit on a page, or if Page Breaks 

have been specified in the Table Settings. 

Auto Adjust When a Table is too large to fit on one page, this setting instructs VoxcoTab to 

try and fit it on the page by reducing column widths (while maintaining 

readability of their contents, or course). If it is unable to achieve this, the 

original column widths will be maintained. 

Center 

Vertically/Horizon

tally 

These settings position the table within the page. 

First Page 

Number 

This first  page number applies if page numbering is requested (see below). 

Margins These margins are specified in millimetres (1 inch=25 mm). You can set margins 

for Top, Left, Right and Bottom. The Header and Footer margins apply to the 

space before them??? 

Header 

(applies also to 

Footer) 

The Header consists of one or more lines. You can insert or delete lines with a 

right-click in the line No. column, or by using the Insert/Delete keys. 
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A right-click in a line's No. column also enables you to determine the line Height. 

You can specify a Fixed height in millimetres or select the Auto option. It is 

strongly recommended that you use the Auto option (unless you have a special 

situation such as an image etc.). The Fixed option with a value of zero would 

make a line disappear, even if it contained information. 

Each line consist of three parts (Left, Centre, Right). You can determine the 

content (text, variables, images) and format of each part.  Press any key or 

double-click in the selected part to bring up the Expression window in which you 

can compose your text (in the field at the bottom of the window) including any 

of  the listed variables (by double-clicking them).  Variables are inserted in 

square brackets prefixed with the & character: 

 For example: Study title displays the title of the study, Page title displays the 

complete title of the variable(s) in the page together with the current categories, 

for example: Sex: Male. 

 The VLPage (Vertical logical page title) and HLPage (Horizontal logical page 

title) refer to the titles defined for the Index (see Index). 

The Threshold option displays the confidence level chosen for Tests. 

The Counts Legend and Means Legend options display legends (grid) showing 

the positioning of items in the table cells. Example: 

  

A right-click in a part allows you to: 

• Clear (Reset) the part 

• Specify Font attributes 
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• Set Horizontal and Vertical alignment of the contents 

• Insert an image (a logo for example) 

Separator: Allows you to insert a line (thick or thin) after the header, and to set 

its colour. 

Header Background: Allow you to set a background colour for the header. 

Space After: Determines (in mm) a space after the Header (or before the 

Footer) 

Footer (the above description of a Header equally applies to a Footer) 

Load/Save 

buttons 

Allow you to Load an existing Stylesheet  or to save the current settings as a 

new Stylesheet under a user-defined name. 
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Page Index 

The Table index is accessed through the Page Index button  in the Toolbar. 

When a table is divided into several logical pages by means of the Page Break check-boxes in a Table 

Request, the title of each page that appears in the Index can be edited. 

 

These titles are initialized with the name of the variables determining the page breaks, you can simply 

replace them with your own text. 

Note: To be visible, these titles must be inserted in a table Header or Footer (see Logical Page Titles in 

Page Settings). This enables each logical page to bear its own title. 

The Styles tab allows you to assign Styles (font, size, colour etc.) to the different titles (Study, folder, 

request, page, column, row.) 
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Printing tables 

The Print dialog window is accessed through the Print button  in the Toolbar. 

You can output the tables to a Printer or to PDF files first having used the Properties button to access the 

Page Set-up. Any Page Breaks set in the Table Request will generate page breaks before the output of 

their associated variables. 

If the Print Index option is checked, a summary will be printed at the top of the table, providing on each 

logical page (obtained with the Break options) the titles included in the Index screen (see Page Index) 

together with the corresponding page number. 

 

Note: The Portrait or Landscape orientation chosen in the Page Set-up will be conserved i.e. it does not 

have to be specified again each time that the table is printed. 

Printing several requests 

If you click on the Print button when you have several requests selected, the output will contain the tables 

for all the requests. The same applies when a request folder is selected; all the requests will be included. 

Note: When you use the Print Index option, page numbering for the complete set of tables is sequential 

i.e. any First Page number specified in the Page Settings window will not apply. 

UsingPDF Creator 

Standard PDF printing uses Acrobat whose execution times are very long, excessively so when hundreds 

of pages are involved. For this reason we recommend installing PDF Creator (free application supplied with 

VoxcoTab) which delivers very satisfactory execution times. Once installed, PDF Creator appears in the list 

of available printing devices. 

Page Preview 

The Page Preview  button in the Toolbar enables you to see the table on screen, formatted the same 

way as it will be printed. 

The Printer dialog window (see above) allows you to select page size and also determine whether the page 

orientation is "portrait" or "landscape". 

This button can apply to one or more requests or folders. 
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Gamma  (Goodman et Kruskal) and Chi Squared tests. 

These tests  are available through a right click when previewing the table. The results are provided in a 

window, with the possibility of exporting them in CSV format. 

The Gamma test is used when both the row and column variables are ordinal. The Chi Squared test is 

computed for the full table, while the already existing Chi2 test applies to each cell of the table. 

The results for every table are: Chi2 value, Degrees of freedom, Value of U, Goodness of fit (+, ++ and 

+++ at 90, 95 and 99% levels), and an indication of the validity of the test. 

 

Notes:   

• The table should include a row and a column Total, (obtained with the template option T, or NT, 
or A), weighted or not as are the cells in the table. 

• There should not be more than one D option for one table in a templates whether it be in the 
rows or columns. 

• The format of variables in rows and columns should include individual values, and not just sub-
totals: chi2 is calculated for the sub-table made only with these rows and columns, and all the 
rows and columns corresponding to the sub-totals are excluded from the calculation of chi2. 

• In the case of several totals (weighted or not as are the cells in the table), they will be taken into 
account in the following order : first NT ( arithmetic totals), next T, next A (respondents). Thus, 
in the case of multiple variables, the user has the choice between  a  Chi2 computed on the 
arithmetic totals of the table (when using the NT option), or on the logical totals (number of 
respondents, including or not the ‘No Answers’ (T and A options). 
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Exporting tables 

The Export tables feature is accessed through the Export button   in the Toobar. 

The format options are XLS for Excel, CSV,  or HTML. The option can be made for a request or a folder. 

With all options the complete table set is obtained, including all the displayed values (counts, percentages, 

etc.) together with titles and category labels. Table Settings (hiding empty rows and columns, hiding 

percentages etc.) are implemented. 

The XLS (or XLSX when more than 256 columns are required) option produces an MS-Excel-readable 

file, which can contain several sheets, reflecting the page-layout settings (bold text, colours, font sizes 

etc.): 

• If the table has a Page variable, there will be as many Excel sheets as there are pages. 
Furthermore, a separate sheet is created wherever a Page Break is requested in the Table 
Request. 

• The Index is always supplied in the form of an additional tab  titled 'Index'; it provides a list of 
the other tabs. 

The CSV option produces a single sheet. It contains, in addition to Titles and Labels (in the 2nd column), 

two additional columns: 

• The 1st column contains a code 0-3 indicating whether the Row corresponds to a Title (code 0 
for 1st Stage Title, code 2 for 2nd Stage Title) or to Results (code 1 for 1st Stage Results, code 
3 for 2nd Stage Results). 

• The 3rd column contains a code 0-2 indicating which line of sub-cells corresponds to the 
presented results. 

The HTML option can be in the form of a mini-site, or as a single file. In mini-site form, the folder will 

contain a set or files readable by Internet Explorer; the files separated into pages conforming to page 

breaks specified for the table. The legend appears to the left taken from the contents of the Table index 

screen obtained with Index icon. 
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Table Requests at the Folder Level 

The Table Request buttons in the toolbar are also available at the Folder Level. 

Button Description 

Execute All the requests in the folder will be executed 

automatically 

Table Settings Enables table settings to be defined applying to all 

requests in the folder 

Page Settings Enables the page settings to be defined applying to 

all requests in the folder 

Print Preview   

Print All tables in the folder will be printed as a single 

document 

Export All tables in the folder will be exported into a single 

file 
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Row and Column Operations 

In a Table Request, you can create new Columns or Rows based on arithmetic operations on other 

Columns or Rows. 

Table Requests 

In the Table Request window, when you click on the button to the right of a Variable field (whether it be 

for a Stub or Banner),  the Variables/Expression window appears; it consists of two tabs: Variables, 

Expressions. Instead of selecting a variable in its Variables tab, you can use the Expressions tab to define 

the "variable" in term of other Rows or Columns, depending on whether you defining a Row or Column 

respectively. 

Using this feature, you can define a Column as the sum of several other Columns, or the relationship of 

two columns etc. These new computed Rows and/or Columns must be created before executing the Table 

Request, even through the computation formula can be modified afterwards. 

The Expression tab contains a Title field and an Expression field where you can type your 

formula/expression: 

 

The Title will be displayed in tables at the same level as Variable titles. 

The Expression is an arithmetical formula (with optional parentheses) involving: 

• Existing line numbers, in the form Lnn (where nn is the number in the first column of the Table 
Request), whether the Expression is being defined for Rows or Columns in the table. 

Notes: 

o The referenced lines must contain Variables, Expressions. 

o If the operation is at the 1st Stage, it must not be followed by a 2nd Stage, and the 
referenced lines must also be at the 1st Stage. 

o If the operation is at the 2nd Stage, the referenced lines must be at the 2nd Stage in the 
same group. 

o Referenced lines must correspond to variables whose attached Template comprises a single 
Option. And this Option must be neither D (Distribution) nor LO (List of Occurrences). 

o Care must be taken when deleting, inserting or moving lines. When doing so, it will be 
necessary to modify the referenced line numbers (this does not apply when specifying 
Bases for Percentages). 

o It is possible to reference not just a complete Row or Column, but a single element whose 
position, as it will appear when the table is displayed on the screen, is known. For 
example: L3[1] references the element in the 1st column of the resulting table (when 
operating on Rows) or the 1st Line (when operating on Columns). It must be noted that 
this index does not take into account Rows or Columns which are blank or whose display is 
suppressed. 

• Integer or real number constants 

• Arithmetical operators: + - * /   
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• Functions: 
  

ABS Absolute Value 

SQRL Square Root 

ROUND Rounded 

TRUNC Truncate 

RANDOM Random number between 0 and 1 

EXP Exponent 

LOG Natural Logarithm 

ISP Returns 1 if the argument is positive or Null, 0 otherwise. 

ISZ Returns 1 if the argument is equal to zero, 0 otherwise. 

ISSP Returns 1 if the argument is Positive, 0 otherwise. 

Note: Before closing the Expression window, the expression must be confirmed with the Set or Add 

button. 

Assigned Template 

The Expression must be assigned a Template whose function is to provide: a Title in the table display (in 

the line corresponding to variable labels), the number of decimals, and the Hide attribute. Any other 

Options and Attributes in the Template will be ignored. This Template must consist of a single line. 

Execution 

Execution is performed after the breakdown, and after means and percentages have been computed. This 

being the case, you can modify the computation expression after you have taken a look at the resulting 

table. 

Operations are based on counts (typical case), sums (C Option in the Template) or Means (M Options in 

the Template) in the referenced argument element. 

When the formula is applied, the result will be Null if: 

• A computation is impossible (division by zero etc.) 

• One of the operands is empty. 

Rows are computed first, and then Columns. 
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Export 

Export 

All or a sub-set of a study's variables can be exported to files in different formats: 

• VoxcoTab format 

• SPSS format (SAV) 

• COSI format 

• SPAD format (SDA) 

VoxcoTab format comprises 3 files: 

• A Data file bearing a .ASC extension, in either fixed column or delimited format. 

• A Study file bearing a .SDB extension, i.e. a new VoxcoTab study. 

• A file bearing a .MAP extension, comprising a list of the variables and the positions of their data 
in the data file. 

Hence the user is provided with a complete VoxcoTab study, ready for immediate processing with the 

VoxcoTab application. 

COSI format comprises 2 files: 

• A Data file bearing a .ASC extensions in fixed column format. 

• A file bearing a .SCT extension i.e. the COSI script (variables dictionary). 

An Export Request 

The Export Requests window is accessed through the Utilities>Export menu: 

 

You can Add, Update, Delete, Duplicate and Run a Request. 

When you access a Request, the following window appears: 

 

Title: Any title you wish to give to the Request 

Universe: This can be used to specify a logical variable to be used as a Filter. Only cases which are TRUE 

for this variable will be exported. 

VoxcoTab, SPSS or COSI tabs: These are used to bring the appropriate specification window into view. 
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Export to VoxcoTab 

You must provide: 

• The path to the folder in which the study will be created (the filename must not be specified) 

• The Study Number of the study to be created 

• The type of File Format for the data file: ASCII or CSV. For a CSV file, you must specify the Field 
Separator and Text Delimiter. 

• If you select the Code to Label option, variables with Formats will have their category labels 
rather than category codes exported. 

 

The files created will bear the following names (where nnn is the specified Study number): 

• E_nnn.asc 

• E-nnn.sdb 

• E-nnn.map 

To choose which variables to export, click on the button to the right of the Variable field; the Choose a 

Variable window will appear, allowing you to select one or more variables: 
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Once you have selected your variables, for each variable, specify: 

• Field length (for ASCII files only; for CSV files it will be ignored) 

• Number of Decimals. 

• For multiple response variables: The By Values option. If checked the data will consist of a series 
of codes in successive fields). If unchecked (a series of 0 or 1 values indicating the 
corresponding codes). 

• For multiple response variables: The number of values to be considered. 

• The value which is to indicate MISSING (blank by default). 

• Use of UTF8 characters or not allowing Text variables containing Chinese or other exotic 
characters. 

In Export Requests (VoxcoTab, SPSS, COSI and SPAD), you can move an already selected variable : select 

the variable and press the CTRL + Up/Down arrow on your keyboard. 

For Dimensioned variables, the occurrences are automatically written one after the other. 

Autosize option. When you click on the Autosize button, all the properties described above (field length, 

number of decimals etc.) will be automatically set by the program; it does this by reading the data file to 

establish the appropriate settings. The only property which you might need to indicate concerns the By 

Values or By Rank option for multiple response variables. You can change these values if desired. 

For Studies with Levels, the selected variables can belong to different levels. For this, the MultiLevel 

option checkbox is provided: 

• When the Multi-Level option is not checked, only cases belonging to one (and only one) level 
will be exported, the level determined by the highest Level number present in the selected 
variables. Selected variables with a lower Level number are also be exported in the same record, 
and at the same level. 

• When the Multi-Level option is checked, the new study created will be Multi-Level, and the 
ASCII file created will comprise multiple records (one per level). 
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Export to SPSS 

You must provide the path to the folder in which the study will be created (the filename must not be 

specified) 

Variables are selected in the same way as for Export to VoxcoTab together with the same attributes. 

In Export Requests (VoxcoTab, SPSS, COSI and SPAD), you can move an already selected variable : select 

the variable and press the CTRL + Up/Down arrow on your keyboard. 

 

Notes: 

• Multiple variables are split into as many variables as the number of values specified. 

• Dimensioned variables create as many variables as there are occurrences. 

• The Autosize option works the same as in Export to VoxcoTab. 
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Export to SPAD 

The procedure is the same as for SPSS. Use the SDA extension for the file to be created. 

 

Export to COSI 

You must provide the name and path to the script file (.SCT) and the data file (.ASC). 

 

Variables are selected in the same way as for Export to VoxcoTab together with the same attributes (field 

length, number of decimals etc.). The Autosize option works the same as in Export to VoxcoTab. 
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Weighting 

Weighting 

Overview 

This module computes a weight or adjustment factor for each case in the sample given one or more 

weighting criteria. The weights are computed so that the structure of the weighted sample conforms to a 

given theoretical structure. 

The computation procedure is iterative. 

Weighting adjustment can apply either to numbers of cases or quantities associated with them. 

The results are provided in the form of a file containing a weight for each case that has been processed. 

The file must then be declared as an External Table for the study, so that the weights can then be 

accessed. 

The necessary elements are the following variables: 

• Weighting variable (Quantity type) which will store the adjustment weights. 

• Identification variable (Text type) which uniquely identifies each case in the output file. 

• Weighting criteria (Single type) which are processed individually or in pairs (crossed criteria). 

Weighting request 

The Weighting Request window is accessed through the Utilities>Weighting Factor menu: 

 

You can Add, Update, Delete, Duplicate and Run weighting requests. 

A request is configured in the Weighting Factor Request window shown below. The Title field is for any 

text string to describe the request. The Options tab is for providing general options, while the Criteria 

tab is for specifying the adjustment criteria and their objectives: 
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Options (tab) 

 

  

Setting Description 

ID (Obligatory) Text-type variable for identifying cases in the weights output file 

Base (Optional) Logical-type variable describing the Universe (Filter) on which the 

weighting is to be established 

Weight (Obligatory) Quantity-type variable in which the weight for each case will be 

stored 

Initial weight (Optional) Quantity-type variable. Values in this variable will be used as initial 

weights to start the iterative computation process. 

Note: This feature was introduced to satisfy a client request, however we do 

not recommend that you use it. 

Quantity to adjust (Optional) Quantity-type variable. If used, the weighting will apply not to 

numbers of cases (or percentages of them) but to volumes (or percentages of 

these volumes). For example, in an agricultural study dealing with land usage 

(acres) for wheat cultivation, we might want to weight on the basis of wheat 

production (tons) rather than the acres used. 

Max interations The maximum number of iterations (300 by default). It is recommended that 

you leave this value unchanged, except in special cases. 

Threshold Difference between targeted values and those obtained during the process 

below which the iterative process will be terminated. It is recommended that 

you use the default value (0.1). 

Weight is null if less 

than 

Weights less than this value will be replaced by zero. 
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Null weight is 

considered 

Null weights can be converted to zero or MISSING. 

Weight range Weights will be limited to the Maximum and Minimum callues specified. 

Target in Targets specified for each of the criteria can be specified in either values or 

percentages. 

Extrapolate to If this option is not selected, the weighting will produce a total count equal to 

the unweighted sample. If selected, you specify the total number of cases (or 

total quantity if applicable) to be obtained after weighting. Note: You supply 

the total number of cases even if Target is specified in percentages (see the 

previous option) 

This option is obligatory if: 

Note: This option is obligatory if there is a quantity to be adjusted. However, 

it is not necessary to check this option if objectives are provided in values. 

  

Studies with Levels: Weighting applies to a single level, by convention the level of the ID variable. 

Consequently, the Weighting variable must be at the same level; the same applies to the Initial Weight 

and Quantity variables if they exist. The criteria must be at the same or higher level (i.e. the same or 

smaller level number). 

Criteria (tab) 

The References field enables you to select one or more criteria, whether single or crossed. These criteria 

must be Single-type undimensioned variables or occurrences or a dimensioned variable, and they 

must have a Format categories. Targets must be supplied for each and every single-code category i.e. 

any categories grouping together several codes will be ignored. 

      

Targets must be supplied for all of the displayed categories, including the value MISSING???. You can use 

copy and paste functions in the Target column. 
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Important note: By convention, the category NA here represents all cases which are not classified into 
the Format's category list. It includes, therefore, the true MISSING for the variable (as it appears in 
tables), together with all values for the variable which are not encompassed by the Format categories. 
Hence, the NA considered here is not the same as that which appears in tables under the N (No Response) 
Option in Templates. 

Keep NA values check-box: With this option selected, no target is supplied for NA category (it no longer 

even appears in the list). The weighting module will compute an adjustment weight which will maintain 

the same proportion of NA cases as in the unweighted sample. 

Crossed criteria 

In this case, a target must be supplied in each cell of the table produced by crossing the 2 selected 

variables: 

 

Note: When using crossed-criteria, the Keep NA values option may no longer be checked. 

Execution 

The execution produces 2 files (nnn : study number, ddddddd : request title): 

• Weights file: Wnnn-ddddddd.txt 

• Report file: Wnnn-ddddddd.log 

The Weights file contains a line for every case belonging to the chosen Universe (Filter) consisting of the 

case ID together with its weight. This file must be set up as an External CSV Table, with the ID variable 

used as index key linked to the first field in the table. The weight must read in by means of the 

ImportsCSV function in the second field. 

This file will not contain any case whose ID or initial weight is MISSING. 

The Log file reports on the execution, it lists the options and settings, and, for each criterion, the 

requested value, initial values in the sample, and adjusted values. 

The user is also provided a result in the log file : efficiency. 

Efficiency = 100 * (Σ weight)² / n Σ weight² 
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Procedures 

Overview (Procedures) 

Description 

A procedure is a custom CPL function which you define using the CPL (Cotab Procedural Language) 

language. This language allows you to perform all sorts of arithmetical, logical, and test operations 

including iterative loops. You define a procedure in the Variables window by choosing a CPL function in the 

Function column. You can import a procedure from another study by importing the variable to which it is 

assigned. 

 

Creating a procedure 

The Procedure definition window is divided into two panes: the upper pane is where you write the 

procedure itself. 

You type the procedure in free format making use of the standard text editing key combinations: Ctrl C 

(copy), Ctrl V (past), Ctrl Z (undo), Ctrl A (select all), Insert, Delete, Enter. 

The "Parse" button tests the syntax of the procedure. 

The "Debug" button switches to Test Mode: when you click on the "Next" button the lower pane displays 

the result of the "Debug" instructions applied to the first (next) case in the data file. 

The "Back to First" button returns to the first case in the data file. 

The "Stop"button switches back to Edit mode in which you can continue modifying the procedure. 
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CPL Language 

Symbols and notation 

Definitions 

CPL language has a relatively simple syntax Available symbols in CPL are: 

• System symbols 

• Keywords 

• Study variables 

• Local variables 

• Constants 

Note:  Variable names are case-sensitive (upper and lower-case must be respected). However, system 

symbols and keywords are not case-sensitive. 

Symbol Description 

System Symbols System symbols are identified by their first character which must be "@". 

This is followed by one or more characters, for example: @begin, @end, 

@na, @ind, @write, etc. 

Keywords These reserved keywords consist of one or more characters: IF, FOR, 

CONTINUE. 

Study Variables These are variables defined in the Variables list (dictionary), and which 

must precede the procedure in the list. 

Local Variables These variables must be declared before they are referenced (using an 

instruction such as var S a,b). A local variable can be declared anywhere 

in the procedure. The first character in the name must be a letter, the 

other characters are alphanumeric (the "_" (underbar) character is 

permitted, however the name must not be a CPL reserved keyword. 

Note that there are several differences between Local and Study 

variables: 

• At the start of execution, local variables are initialized with the 
value of 0 for types S(single) or Q(quantity), MISSING for type 
M(multiple), "" for type T(text), and FALSE for types L(logical). 
Study variables, on the other hand, are initialized as MISSING 
for each new case. 

• The value of a local variable is not modified by VoxcoTab during 
execution of the study. 

  

Constants Numerical constants may be of type S (Single) or Q (Quantity); CPL 

automatically recognizes constant types. For example: 123 is type S, 

while 123.0 or 123. are type Q. Literal constants must be enclosed within 

quotes ""; and if the " character forms part of the literal constant, it must 

be preceded by the character ^. For example: ^"OK^" 

System symbols 

Symbol Description 
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@begin and @end Section markers indicating the start of a beginning and ending section 

respectively. 

@na MISSING constant 

@write Indicates the file (name and directory) to which messages obtained with the 

write function are to be written. 

Example: @write filename    " c:\\xxx\\test.log" 

"filename" is the name, internal to the procedure, to which write instructions 

make reference. 

You can define several files to which the procedure may write. 

@ind A S(ingle) type system variable which returns the occurrence index in the 

implicit loop or a dimensioned instruction. For example, to initialize a 

dimensioned variable STAB, the 2 following instructions are equivalent: 

STAB = @ind 

for (i =0 ; i<=dim ; i++) {STAB[i] = i} 

Comments Two types of comment indicators are supported: 

// makes all characters that follow it to the end of the line into a comment. 

/* */ delimiters enable several lines in a procedure to be ignored. 

Variable types and implicit conversion 

Types of variable 

Both study variables and local variables can be of the following types: 

M Multiple response 

S Single response (numeric 

integer) 

Q Quantity (numeric with 

decimals) 

T Text 

L Logical 

  

Local variables, whose type must always be specified, are declared as follows: 

var M m1, m2, m3[200], m4[10] 

Whenever a variable or constant is used in an instruction, CPL automatically performs an implicit 

conversion if necessary. The conversion does not destroy the variable's type, nor its original value. Note 

that an instruction requiring automatic conversion is not as fast as an instruction that does not require it. 

Rules for conversion between types 

Source 

type 

Destination 

type 

Description/Example 

Multiple Text Example: 2,3,5 becomes "2,3,5" 
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Quantity Single The value is rounded. 

Example: 2.34 becomes 2, 3.5 

becomes 4. 

Single Multiple If the value is >= 0  the value is 

assigned to M, otherwise M is set to 

MISSING 

Quantity Multiple The conversion is executed in 2 steps: 

Q is converted to S, then S is 

converted to M 

(see above) 

Multiple Single or 

Quantity 

If the variable M is MISSING the result 

is MISSING otherwise the minimum 

value is taken 

Single Text 2005 becomes "2005 " 

Quantity Text 2.34 => "2.34" 

MISSING     

  

and  MISSING => "" or "  " ??? 

Thanks to automatic type conversion, you can write the following instructions in CPL: 

var M m 

var T text 

var S i 

var Q q 

m = "2,4,10" // T => M 

q = "2.34" // T => Q 

text = m // M => T 

i = q // Q => S 

i = m // M => S 

Structure of a CPL procedure 

A procedure is a user-defined routine which VoxcoTab calls when a study is being executed. 

It can comprise any one or both of 2 section types, each of which is must be enclosed within brackets 

{},  together with variable declarations which can appear anywhere in the procedure: 

1. Beginning section. This section is executed only once at the beginning of the study 

2. Body section. This section is executed for each case in the study 

Here is an example of a simple procedure containing both section types; each one is explained by means 

of comments: 

var Q cumul_POIDS  // initializes  the internal variable cumul_POIDS to 
0.0 

@write outfile "C:\\RESULTS\\RES.TXT" //assigns internal filename 
referencing 
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// an external file 

@begin // This marks the start of a begin section which will be 
executed once only at the beginning of the study 

{ 

  var S Total  // initializes it to 0.0   

  // The instructions in this section are executed once at the start of 
study    

  // execution, and before the data file is read. 

  // Called by the main VoxcoTab engine, in the order that they appear 
in the 

  // dictionary. 

  Total = 0 

} 

{ 

  // This is the body section. The instructions in this section are 
executed for each case 

  // at the level of the procedure. 

  // Called by the main VoxcoTab engine, in the order that they appear 
in the 

  // dictionary. 

  Total++ 

  cumul_POIDS += POIDS 

} 

Each of th 2 sections is optional. Each one, if present, must have at least one instruction other than a 

declaration of variables. 

The exit instruction is not allowed within a @begin section. 

Study variables are not accessible within a @begin sectioni.e. they are only accessible in the body section. 

Local variables (specific to the procedure) can be declared anywhere, within or outside a section. 
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Basic CPL instructions 

CPL (Cotab procedural language) is a free-form structural language. 

Instructions are usually terminated by one or more carriage-returns, but some expressions can be written 

on several lines; in particular certain characters such as ")", "=" etc. can be followed by a carriage-return 

in the middle of an instruction since CPL knows that the instruction is not yet complete. 

Dimension of instructions (CPL) 

The notion of dimensions for instructions is a very important feature of the CPL language. It enables an 

instruction or block of instructions (with a branching structure, described below) to be carried out 

occurrence by occurrence on dimensioned variables (possessing the same dimension or no dimension). 

This is a natural generalization of the execution of Cotab functions when applied to dimensioned variables. 

General Rules 

The dimension of a basic instruction is determined by that of the variables involved in the instruction. 

Variables must all be of the same dimension or have no dimension. 

The CPL engine executes a dimensioned instruction with an implicit loop whose range is 1 to the 

dimension of the instruction. 

The system variable @ind can be used in a dimensioned instruction; it takes on the value of the 

occurrence index within the implied loop (@ind is always 0 in the case of an instruction that has no 

dimension). 

For example, take a dimensioned variable CNBHB and a local un-dimensioned variable cumul. The 

following 2 instructions achieve the same result: 

• cumul += CNBHAB  // the instruction has dimension = CNBHAB.dim 

• for (i=1; i<=CNBHAB.dim; i++) 
{ 
cumul += CNBHAB[i] // un-dimensioned instruction 
} 

Accessing an occurrence of a dimensioned variable 

For a dimensioned variable named var_tab, the expression var_tab[arith_expr] enables you to obtain the 

occurrence of var_tab whose index is returned by result of arith_expr. 

Example : var_tab[3], var_tab[i*3+j], var_tab[(i+j)*3+k], etc. 

Increasing/decreasing a value 

There is often the need to increase or decrease the value of a numeric variable (type S or Q). CPS 

provides two instructions for the purpose: 

variable++ // the variable is increased by 1 

variable-- // the variable is decreased by 1 
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Assignment instructions 

variable = expression   

expression can be: 

• (expression) 

• Numeric_Expression 

• Logical_Expression 

• Text variable or constant 

 A Numeric_Expression can be: 

• Numeric_Expression + Numeric_Expression // addition 

• Numeric_Expression - Numeric_Expression // subtraction 

• Numeric_Expression * Numeric_Expression // multiplication 

• Numeric_Expression / Numeric_Expression // division 

• Numeric_Expression % Numeric_Expression // modulo 

• Numeric_Expression ** Numeric_Expression // power 

• Math_Function (Numeric_Expression) 

• Min(argument1[, argument2, ...])       // argument must be un-dimensioned. 

• Max(argument1[, argument2, ...])      // argument must be un-dimensioned. 

• NbRep(Multiple_Variable) 

• Length(Text_Variable)    

• Numeric_Argument (variable or constant of type S or Q) 

where Math_Function can be one of the following mathematical functions: 

o ABS : absolute value 

o SQRT : square root 

o ROUND : rounding 

o TRUNC : truncation 

o RANDOM : random number between 0 and 1 (there is no argument with this function) 

o EXP : exponent 

o LOG : naperian logarithm 

o ISP : returns 1 if the argument if positive or null, otherwise 0 

o ISZ : returns 1 if the argument equals 0, otherwise 0 

o ISSP : returns 1 if the argument is positive, otherwise 0 

Logical_Expression can be 

• Logical_Expression & Logical_Expression // AND   

• Logical_Expression  | Logical_Expression  // OR   

• Logical_Expression  ~ Logical_Expression  // EXCEPT   

• Logical_Expression  ^ Logical_Expression  // XOR 

Priority between arithmetic operators is:   

 ** then *, /, % then +, -. 

There is no priority between logical operators. 
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Example 

 

Other forms of assignment (shortform) 

Single/Quantity_Variable += Numeric_Expression // Single/Quantity_Variable = Single/Quantity_Variable 

+ Numeric_Expression 

Single/Quantity_Variable -= Numeric_Expression // Single/Quantity_Variable = Single/Quantity_Variable - 

Numeric_Expression 

Single/Quantity_Variable *= Numeric_Expression // Single/Quantity_Variable = Single/Quantity_Variable 

* Numeric_Expression 

Single/Quantity_Variable /= Numeric_Expression // Single/Quantity_Variable = Single/Quantity_Variable 

/ Numeric_Expression 

Single/Quantity_Variable %= Numeric_Expression // Single/Quantity_Variable = Single/Quantity_Variable 

% Numeric_Expression 

Single/Quantity_Variable **= Numeric_Expression // Single/Quantity_Variable = 

Single/Quantity_Variable ** Numeric_Expression 

Multiple_Variable &= expr_log // Multiple_Variable = Multiple_Variable & expr_log 

Multiple_Variable |= Logical_Expression // Multiple_Variable = Multiple_Variable | Logical_Expression 

Multiple_Variable ~= Logical_Expression // Multiple_Variable = Multiple_Variable ~ Logical_Expression 

Multiple_Variable ^= Logical_Expression // Multiple_Variable = Multiple_Variable ^ Logical_Expression 
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Other functions 

Concatenation of character strings: 

variable = Chain(CHN1,CHN2,...) 

CHN1 is either a text variable or a text constant(« ……. ») 

Replacement of the first appearance of a string (1st argument) by another string (2nd argument) in a Text 

variable (3rd argument). 

  

Replace STRING_FIND , STRING_REPLACE , STRING_RESULT 

Replacement of all appearances of a string: 

ReplaceAll STRING_FIND , STRING_REPLACE , STRING_RESUL 

Example 
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Manipulating sub-strings: 

Strlen ( varT) : returns the length of the string contained in the Text variable varT.  

Strpos (varT, « xyz ») : returns the position of the specified sub-string  xyz first encountered within the 
character string in varT. (the value will be -1 if sub-string xyz doesn’t exist). 

Substr (varT, j, k) : extracts from the variable varT , a sub-string with k characters, starting at position j 
or : 

Substr (varT, j) : extracts from the variable varT, the sub-string starting at position j.  

 

 

 



 

126 

 

Conditional expressions and control structures (CPL) 

Conditional expressions 

Control structures use conditional expressions to control the flow of execution of instructions. When a 

condition is evaluated, the value TRUE or FALSE is returned. 

Syntax 

Expression Description 

(condition) The condition may be enclosed in parentheses 

(condition | condition) OR 

(condition & condition) AND 

(condition ~ condition) EXCEPT 

(condition ^ condition) XOR 

(! condition) NOT 

(argument1>argument2) Greater than 

(argument1>=argument2) Greater than or equal to 

(argument1<argument2) Less than 

(argument1<=argument2) Less than or equal to 

(argument1=argument2) Equal to 

(argument1<>argument2) Not equal to 

(argument1) argument1 is not MISSING 

Note: argument1, argument 2 are variables or constants 

(arg1 = 1, 2, 3) signifies ((arg1 = 1) or (arg1 = 2) or (arg1 = 3)) 

(arg1 <> 1, 2, 3) signifies ((arg1 <> 1) and (arg1 <> 2) and (arg1 <> 3)) 

  

Special case for Multiple variables 

Expression Description 

(MV1 = MV2) TRUE if the intersection of MV1 and MV2 is not empty, or if both MV1 and MV2 are 

MISSING (@na) 

(MV1<>MV2) TRUE if the intersection of MV1 and MV2 is empty and both MV1 and MV2 are not 

MISSING (@na) 

(MV1 > MV2) TRUE if MV1 is not MISSING and MV1's greatest value > MV2's greatest value 

(MV1 < MV2) TRUE if MV1 is not MISSING and MV2's greatest value > MV1's greatest value 

Notes: 

• Precision for Quantity (floating point) variables: Where Q (Quantity) type variables are 
concerned, the tests = and <> can be faulty due to the precision with which the computer 
represents floating point numbers. Some floating point numbers cannot be coded exactly by the 
computer (Cotab uses IEEE double precision standards for internal representation of Q (quantity) 
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type variables and constants). It is recommended that you use a test such as VQ > -0.00001 and 
VQ < 0.00001) in place of VQ = 0.0. 

• Dimension of a simple condition is determined by the variables used in the condition (they 
must all have the same dimension or be undimensioned). 

• Dimension of a combination of conditions is determined by the dimension of the simple 
conditions comprised in the combination (they must all have the same dimension or be 
undimensioned). 

Control Structure 

Control structures are simple conditional instructions (if... else...) or loops (for...) 

Since they are instructions, they can be nested within other conditional instructions or loops. Note that the 

brackets '{' and'}' must be used to enclose 2 or more instructions in the following syntax. 

The dimension of a control instruction is determined by the dimension of the conditional expression used. 

Simple conditional instructions 

Condition

al 

instructio

n 

Description/Example 

if 

(condition) 

instruction 

CPL first evaluates the condition. If it is TRUE, CPL will execute the instruction. 

Example : 

if ((v = 1) & (VQ <= weight1) | (VQ >= weight2)) myvar = VS 

if 

(condition) 

instruction

1 else 

instruction

2 

CPL first evaluates the condition: If it is TRUE, CPL will execute the instruction1, if it is 

FALSE , CPL executes instruction2. 



 

128 

 

Loops 

Loop instruction Description/Example 

for 

([start_instruction

]; 

[condition]; 

[loop_instruction]

)      

   instruction 

CPL first executes the optional start_instruction. 

For the loop, CPL evaluates the condition; if it is TRUE, CPL 

executesthe  instruction then the loop_instruction and then performs the next 

loop. Otherwise, CPL exits from the loop. 

Example : 

for (i = 1; i <= 10; i++) 

{ 

  vs_tab[i] = i 

  } 
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Warning: CPL does not possess any protection against an infinite loop which will cause the study (and 
VoxcoTab) to crash.   
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"Break" and "Continue" instructions 

Sometimes there is the requirement to exit a loop when a particular condition is encountered (sometimes 

known as an exception); the break instruction enables you to exit the loop immediately. 

Example : 

for (i = 1; i <= 10; i++) 

{ 

  // Limit : When i is greater than 

  // the dimension of the variable vs_tab, exit the loop 

  if (i > vs_tab.dim) break 

  vs_tab[i] = i 

  } 

Another requirement is to skip the remaining instructions for the current iteration and start the next 

iteration of the loop. This is achieved using the continue instruction. 

Example : 

for (i = 1; i <= 10; i++) 

{ 

  mytab[i] = i * 2 

  if (i < 3) continue // when i < 3 skip the following instructions 

                // in the loop 

  vs_tab[i] = i 

  } 
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Special instructions 

exit and stop 

To assist in debugging a procedure, and to generate a summary of its execution, CPL provides the 

following special instructions: 

exit: immediately quits one of the three sections in the procedure. 

stop: stops execution of the study. 

Given that a procedure is a user routine called by the main application, the stop instruction cannot 

function as a hard stop to the main application. In its place, the CPL engine sets the main application's 

internal stop flag to TRUE (this simulates a mouse-click on the Stop button or the encounter of an end-of-

file condition). The state of this flag is tested by the main application each time that the entry file is read; 

the application will stop itself before the next read operation. 

For example, while correcting a procedure, you may wish to stop execution when 3 records have been 

read (to avoid having too many debug messages). The following code will do this: 

{ var S  eff 

  eff++ 

  if (eff = 3) stop 

} 

reset 

This instruction deletes the file; it is normally esed in the Begin section of a procedure. 

@reset «c:\\xxxxx » 

where (xxxx is the name of the file) 

debug and write 

debug arg1, arg2,  ... 

write  « filename », arg1, arg2, ... 

The dimension of these two instructions is determined by the dimension of arg1, arg2,... (they must have 

the same dimension or be undimensioned). 

debug displays the message in the lower pane of the procedure window. 

write will write the specified arguments to the file « filename » specified in the @write statement. 
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fwrite 

This instruction writes to a file according a  format which you specify. 

fwrite   "filename" , " {0,n1},{1,n2},{2,n3},… ",  arg1, arg2, ... 

Compared to the write instruction, you must additionally specify the number of characters for each 

argument i thru n which is to be written to the output file. 

 

Important note concerning write and fwrite: the filename specified in the @write instruction is not 

internal to the procedure, it can be accessed in all other procedures. Hence, you can write to the same file 

from several procedures. 
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Example of a procedure 
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Predictive Model 

Predictive Model 

Overview. 

A 'data prediction' problem occurs in a number of situations: 

• Missing values in a survey. 

• Risk Evaluation. Calculating a probability factor to predict abandonment of subscriptions, credit 
defaults etc. 

• Data merging, for the purpose of enriching a client file (for example) based on data collected in 
a sample-based survey. 

The aim is not to create new cases, but to compute values for variables not filled through data collection. 

To handle this problem, the basis is a pilot study (or a model) which provides values to the explained 

variables, on the one hand, and a set of explanatory variables, on the other. 

A data model is thus constructed, which enables the explained variables for each case to be calculated 

on the basis values of the explanatory variables. 

The model uses a proprietary method called RESCUT, which operates using single or multiple explanatory 

variables with Formats i.e. categorized. The explained variables may be of any type (except test). 

Implementation. 

Data prediction makes use of 2 modules: 

1. Model Builder. In this module, you declare: 

o Explanatory variables, Single, Multiple, or Text, with Format (categorized). Non-responses 
are permitted. 

o Explained variable(s), Quantity, Single with or without Format, Multiple with Format, or 
Logical. 

Execution creates the predictive model, automatically stored in a file. 

2. Model Request. You can call this module either in the current study or from another study. In 
the latter case, the variables dictionary must contain both the explanatory and explained variables using 
the same attributes (level, type, dimension and format) as the pilot study. 
 
Execution of this module provides a file containing, for each case, the values of the explained variables. If 
you wish to insert these values into a study, for the purpose of producing crosstabs for example, simply 
declare this file as an external table, and define ImportCsv functions for all the explained variables 

Note: The model will function even if there are non-responses for the explained variables. 
However, this proportion of non-responses will be reproduced in the 'prediction'; this is legitimate 
if the non-response to an explained variable has a precise meaning (example 'Not Applicable'). 
However, it will not be legitimate if the non-response refers to 'Don't Know'. In the latter case, it 
would be appropriate to include in the model a filter to exclude cases with non-responses to the 
explained variable. 

Building the predictive model 

Select Utilities>Model Building in the main menu; this opens the Model Building window. 

You can Add, Update, Delete, Duplicate requests, and Run them 
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A Model Request 

An example of a model request is shown in the screen-shot below: 

 

 A Model Request comprises: 

Setting Description 

Title Any title which will be used in the names of the files created 

Base Optional: The name of a logical variable determining the universe on which 

the model should be created 

Weight Optional: A quantity type variable, if the model is to be created taking into 

account the weight assigned to each case 

Explanatory 

variables 

When you click on the button to the right of a name, you can choose variables 

with a Format (Single, Multiple or Text type) possibly dimensioned 

Explained 

(response) variables 

When you click on the button to the right of a name, you can choose one or 

more variables (any type except Text), with or without Format, possibly 

dimensioned 

If there are several Explained variables, a model will be created for each of 

them 

  



 

137 

 

Executing a model on a data file produces a file in the study folder. Its name will be Mnnn_title.txt, and it 

will contain the model of all the explained variables (nnn is the study number, title is the title of the 

request             

Study with levels 

If the study has levels, the model's level is by convention that of the lowest level variable specified in the 

request (i.e. the highest level number). The model will be built on the cases at this level. All the explained 

variables must belong to this level, otherwise the results will be unpredictable.             

Using the predictive model. 

Select Utilities>Model Using in the main menu; this opens the Model Using window 

 

You can Add, Update, Delete, Duplicate requests, and Run them 

A request is shown in the screen-shot below: 

 

The request requires that you specify the file containing the source model(s) to be used, and a variable 

which serves to identify the cases. 

The study being used must contain the explained variables (with data of course) and the explanatory 

variables, configured with the same attributes as those used in the Model Builder. 

Execution will produce a CSV file in the study folder bearing the name Rnnn_title.csv  (nnn is the study 

number, title is the request title). Each case in the file will have: 

• First field: The value of the ID variable 

• Following fields: The values of the explained variables in their order of appearance in the Model 
request. 

Following execution, you will need to declare this file as an external CSV table, and declare an ImportCSV 

function for each of the explained variables. 
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Simulation 

Overview. 

This module, in the "Utilities" menu, responds to the following question: one often asks,  for example in 
satisfaction surveys, « what is the contribution of items in overall satisfaction? '' . Intuitively, we can 
understand the underlying query, however this wording seems vague and misuse. 

So, we prefer to replace it with this much more accurate and non-disputable statement: what happens 
(what-if?) if, for every item successively and independently, the answers were all the same. For example, 
if the satisfaction study includes questions such as overall satisfaction, then  items like 'speed', 
'friendliness', 'quality of response', etc, we  want to know what happens to overall satisfaction if for 
example all the interviewed were very satisfied with the speed of processing. 

This way of doing gives the influence of every item, all other things being equal.  To make a simulation, 
one should have a variable to simulate (Quantity type, or Single without format, or Single with format,  
or Multiple  with format, or Logical), and categorical explanatory variables, i.e. Single or Multiple, or 
Text type, in these 3 cases with a format.   

Of course, the simulation is based on a predictive model built previously. 

Simulation request. 

You should first build the predictive model (menu ' utilities') corresponding to the variables to be 
explained and explanatory concerned. Then, by clicking on the line 'simulation' in the menu 'utilities', you 
get a screen to create simulation applications. 
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You can create requests, modify them, duplicate them, delete them, run them finally. A request 
corresponds to the screen below. Must be given:  

− the name of file, created by «predictive model building», containing model to use, 
− an ID variable to identify individuals   
− for each listed explanatory variable, the 'target', i.e the value to give to this variable for 

 all individuals of the file. 

 Notes: 
1) If there are several variables to explain in the predictive model, the simulation relates 

only to the first. 
2) Multiple explanatory variables are not considered in the simulation.  
3) The explanatory variables of type Text are taken into account, but should be written 

with care (e.g. ' very satisfied') 

 

Run will provide, in the directory of the study, a csv file, named Snnn_title.csv, (nnn is the number of 
the study, title being the title of the request), with, for each individual: 

-  first field: value of the variable ID 

-  following fields: values of the simulated variable for each simulation: a simulation 
corresponding to one explanatory variable taking, for all individuals, the value in the field 'target' 
(target). 

You can declare this file as an external csv table, and use an Import-csv function to get  the value of the 
variable for all simulations.  

Comparison of all these values will give the respective action of all explanatory items. 
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Export CoTab Reader 

Export CoTab Reader 

Overview. 

The purpose of this Utilities module is to prepare for a customer a tool called CoTabReader for viewing 

study tables, and for building all other tables he/she might require. 

The tool delivered to the end customer includes: 

• A database consisting of study cases, variables, and tables. 

• The software, a subset of CoTab, for building new tables. 

This software CoTabReader is freeware (no license required), but it only works on the exported study, and 

it does not access the modules Export Data, Weighting, and Predictive Model. 

The variables in the database cannot be changed by the CoTab Reader user, but he/she can build new 

variables from existing ones with most of CoTab functions. 

Creating a Cotab Reader for a given study.. 

In the main menu click on Utilities>Export Cotab Reader. In the screen appears you can create 

requests, update, duplicate, delete, and finally run them. 

The Variables tab allows you to select the variables that you wish to export in the database, 

The Requests tab allows you to select the table folders that you wish to export. 

You can export all or part of the cases, some or all of the variables, some or all of the tables. 

The request must be consistent, if not a test error occurs at run time, and the execution does not occur. 

Running CoTab Reader. 

Running CoTab Reader creates, in the requested directory, the software CotabReader paired with 

the  exported database. This entire directory can be copied onto any computer to be run freely. 

CoTabReader. 

By clicking on CoTabReader.exe, the user enters directly into the associated study. 

• The user cannot modify existing variables, but can create new ones, built from existing ones. 

• The Preview and Frequency Tables options are available. 

• The Templates are initialized with those of the original study. In Tables, the folders that were 
selected on exportation are included. 

These tables can be run, printed or exported. New tables can be created using all the features of CoTab. 
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CoTab Reader 

CoTab Reader - Overview 

CoTabReader is a software application for editing statistical tables. It runs under Windows (XP, VISTA, 

Windows7), with Framework 3.5. installed. 

It operates on attached studies created by the Voxcotab application, and enables you to: 

• View existing tables 

• Build new tables 

• Create new variables 

An attached study comprises: 

• Variables (already created) 

• Templates for configuring tables 

• A set of tables 

On launching the application, the following screen appears: 

 

The Variables tab displays existing variables, and allows you to create new ones. 

The Templates tab displays existing templates and allows you to create new ones. 

The Tables tab displays existing tables, and allows you to create  new ones. 

Note: These abbreviated instructions deal with Tables only. 
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Attributes of Variables. 

The chief attributes of variables are Type, Dimension, and Format. Studies with levels also possess the 

Levels attribute. 

Types of variables:  S (single), M (multiple), Q (quantity), T (text), andL (logical) are the types typically 

used in statistical processing. However, note that a logical variable can only have a value of True or 

False,  and that other variables can only have a value corresponding to their type or the conventional 

Missing value. 

Dimension: Used for a series of variables, for example: a set of 10 items for which a score is requested, 

a list of 30 radio stations  asking for listening frequency etc. 

Format : Variables of type  S, M or T may have a format, i.e. a list of values to be displayed in the tables. 

The format can be viewed by clicking on the button located to the right of the Format field. 

 

Base: For a variable X, this field can contain a logical variable, in which case the variable X only applies 

for the value True of this logical variable. In tables, the total for variable X will be the number of True 

values in this Base variable. 

Viewing an Existing Table. 

When you click on the Tables tab the following screen appears: 

 

One or more pre-defined folders are listed on the left.  A click on a folder displays its table requests. To 

open a table request simply double-click on it (TAB4 for example). 
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A click on the Execute button  in the toolbar executes the table (this step is only necessary if it has 

not already been done). 

Clicking on the Preview button   in the toolbar displays the results. 
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The other buttons in the toolbar are : 

Button Description 

Back 
Returns to the table requests screen. 

Preview/Request 
Toggles between the table's preview and its request. 

Table Settings (see 

image below) 

Opens the page where you specify the table settings controlling 

the way it is displayed: size, font, colours, title styles, choice of 

separators, cell contents (counts, percentages, means) and their 

placement, ordering of rows or columns, statistical tests. 

Note: The table settings can be saved or loaded from an existing 

template. 

Page Settings (see 

image below) 

Allows you to set margins, create page headers and footers, edit 

titles, add logos etc. 

Print 
  

Export 
Export to Excel or Powerpoint 

  

Table Settings 
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Page Settings 

 

Setting up a New Table 

In the Requests screen a right click allows you to insert a new request. It also allows you to copy or 

duplicate an existing one preserving its table and page layout settings. 

On inserting a new request, the following screen is presented: 

 

Weighting The button to the right of the 'Weighting' field allows you to choose a weighting 

variable from the list presented, if the table was adjusted. All 'Quantity' type variables 

in the study are listed. 

Universe You can apply a filter using a 'Logical' type variable from the list presented. Logical 

variables have two possible values: True or False. The table will only include cases in 

the study  that are True. 
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Stubs/Colu

mns 

In these areas you insert the variables to be used in the stubs and columns of the 

table. 

To create the first stub or column you may either use a right click or press the Insert 

key. 

Variables To choose a variable, click on the button to the right of the 'Variables' field to open the 

list. Click on a variable to select it: 

A click on the 'Set Variable' button will add the variable to the currently selected Stub 

or Column of the table request: 

  

The table is now ready to be executed: . Beforehand, however, it is best to verify that there are no 

errors: to do so, click on the 'Check' button . Any detected errors will be shown at the bottom of the 

screen. If there are no errors, you can execute the request and view the results: 
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At this point, as before, you can configure the table, print it or export it. 
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Tables with several variables in rows or columns 

 

Another click on the button to the right of the Variables field reopens the variables selection screen. 

 

After selecting one or more variables you can click on the 'Add 1st stage' button which will place them 

after the first variable. As a result the 'Column' variable will be crossed with each of the 'Row' variables in 

succession. You can do the same with 'Column' variables. 
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The check button  tests for the coherence of the table set-up. 

Templates 

The template associated with a variable in rows, columns or pages of a table specifies what should be 

computed and displayed for this variable. 

The chief options are: 

T : Total for the variable.  This includes the whole 'Universe' unless the variable is associated with a 'Base' 

in which case the Total comprises the number of cases which are 'True' in this 'Base' . 

N : The number of 'No Answers'. 

A : Number of cases (at least one response). 

D : Distribution, corresponding to the rows in the variable's 'Format'. 

M : Mean. 

LO : List of Occurrences (for dimensioned variables). 

The types of variables possible with each template option are: 

Option Variable Type Comment 

T, A, N All types The total  for the variable taking into account any base 

that might be associated with it. 

D Single, Multiple, Text With Format. 

C, M, Mi, Ma Quantity, Single, 

[Multiple, Text] 

M, T: with Format and Values in the Format 

NB,NT Multiple The number of responses for a multiple variable. 

LO All Types Dimensioned variables. 

W Quantity Rarely used 

  

A template is a set of one or more of the above options. For example, the first template shown below 

comprises three options: 
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• Total for the variable 

• Distribution 

• No Answers 

Existing templates can be viewed in the Templates tab: 

 

The 'Default' template is the one selected. 

When you check a table using the 'Check'  button, error messages might appear at the bottom of the 

page. If you click on a message in the error list, the corresponding line in the table request will be 

highlighted in red. Usually errors are due to inconsistencies between the variable and the template. 

Example: Template contains D but variable has no format. 

In the above example of an error in paragraph 4, the variable WQAD's type is Quantity, the template is 

not specified hence the Default template applies; this consists of the variable's Total, Distribution, and the 

number of No-Answers. Given that WQAD has no format, the D option is impossible. 
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Dimensioned Variables 

Dimensioned variables which are selected globally can be expanded by clicking in the corresponding 

checkbox; the effect is exactly the same as if each occurrence had been selected individually. 

 

You can also use the LO template option, by crossing the variable with itself, using the LO option together 

with a classic template. 

For example,  by using the LO option for the rows and the default template for the columns: 

 

  

After execution, the preview is: 
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Requests from a Folder 

The following toolbar buttons are available at the Folder level, not just at the Table Request level: 

Button Description 

Execute 
All table requests in the folder will be executed automatically. 

Table Settings Enables Table Display settings to be defined for all table requests 

in the folder. 

Page Settings 
Enables Page Display settings to be defined for all table requests 

in the folder. 

Preview 
Preview before printing. 

Print 
All tables in the folder will be printed in a single document 

Export 
All tables in the folder will be exported in a single file. 
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Reports (Excel) 

Reports (Excel) 

Overview 

Once tables have been exported in Excel format, one generally customizes a report making use of many of 

Excel’s options and resources. Everything is fine if these tables are satisfactory at first go, and if there is 

no need to apply this work to other data. However, outputting the same tables using a different data 

source file would overwrite the report that had been built in the beginning, requiring all the customization 

work to be done again. 

The Reports module gets around this problem; the steps are as follows: 

1. Select requests from one or more folders containing the tables constituting the base of the 
report. 

2. Output them to an Excel ‘Data Model’ which contains the results of all the tables in a single ‘data’ 
tab (in contrast to the classic Excel export). 

3. Build the report in Excel inside other tabs i.e. not the ‘Data Model’ tab which contains the 
exported tables. 

4. When there is a need to make further edits on the same tables, for example using a different 
datafile, outputting to the same Excel ‘Data Model’ will not overwrite the report. 
In this way your can separate your work into two phases: ‘table editing’ and ‘report 
customization’ respectively. 

5. When everything is correct, you can then generate your final report. 

6. An option also enables you to break out this report for all values of a control variable (known as a 
‘population’ variable). This produces as many reports (Excel files) as there are values for this 
variable. 

7. An Excel macro is provided to copy the tables from the ‘data’ tab to the tabs containing the 
report. It respects their layout, and embodies the links necessary to automatically update the 
report to reflect changes in the tables. 

Instructions 

The ‘Reports’ module is provided under the ‘Utilities’ menu. 

 

Buttons are provided, as usual, to modify, delete or duplicate a report. 
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This module comprises 3 phases: 

• Creation (or modification) 

• Building 

• Running 

Creation 

Select the required folders and table requests 

 

Building 

The ‘Build’ button creates an Excel file with a Data Model tab containing the results of the requested tables 

(assembled in vertical sequence in a single tab), and a ‘Map’ tab. This file bears the name XXX.model.xlsx 

(XXX is the name that you gave it). You can then construct your report in tabs 3,4 etc. 

The Excel macro CotabReports.xla which is provided with the application enables you to easily copy tables 

in the Data tab and paste them into another tab, both respecting the layout and preserving the links. 

  

Notes: 

• It is not necessary to ‘Run’ the tables before launching the ‘Build’: the ‘Build’ command will 
execute the selected tables to edit the Excel file. 

• For the ‘Build’ to operate, the study must be free of any errors, including tables not selected in 
the ‘Report’ command. You should verify this beforehand by using the ‘Check’ button. 

• Filenames and table request names within a folder must, of course, be unique. 

• Do not modify the contents of the Data and Map tabs. 

• Once you have built your report, if you launch ‘Build’ again (for example using a new datafile) 
the XXX.model.xlsx will be replaced, and the new Data and Map tabs will be placed after the 
tabs which you created for your report.  You must make sure that the links in your report tabs 
are consistent with the zones in the Data tab, otherwise you are likely to have meaningless 
results. From one ‘Build’ to the next, the tables must be the same (with the exception of 
additions), have the same structure (no modifications to variable formats changing the number 
of values) etc. 
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Running 

The 'Run' button creates the definitive report in another XXX.xlsx file (the Data and Map tabs do not 

appear). 

 

The ‘All’ option creates a single file corresponding to the complete data file. 

The ‘Split by’ option enables the creation of multiple reports, one for each value category of a selected 

variable (subtotals included). The variable (Simple, Multiple or Text type) must have a format. The name 

of each file will be identified by the label of the corresponding value category. 

Note: When using the ‘Split by’ option it is important to be able to include in each report the name of the 

population in question. For this reason the Data tab includes the name of the population variable in cell 

A1, and the label of the value category in cell B1. 

General Notes 

Several precautions must be take when using the Reports module, some of which are discussed above: 

• There must be no errors in the study, even within tables not selected in the request. 

• Both in ‘Build’ and ‘Run’ phases, existing Excel files involved must be closed. 

• The version of Excel must not be earlier than 2007. 

• Do not make modifications in either the Data or Map tab. 

• From one ‘Build’ to another for the same report requests, and also in the ‘Run’ phase, the tables 
must not be modified: no new tables (except appended ones), no changes in the number of 
columns or rows in a table. To summarize, the structure of the Data and Map tabs must remain 
the same, otherwise the links enabling the copy of cells between the Data tab and reports will be 
faulty. It is up to you, the user, to make sure that this consistency is preserved. 

• For the same reason, we strongly advise you not to use ‘remove empty columns’ or ‘remove 
empty rows’ in the tables, since from one data file to another the number rows or columns could 
vary. 
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VoxcoTab Main Menu 

Menu   

 

  

 

  

 

Note: Click on any item in 

the Tools menu for detailed 

information. 

 

  

  

 


